1. #1

    Serious mouse lag in odyssey

    When i launch assassins creed odyssey my mouse starts getting serious levels of input lag; for some reason only while in the game world (menu and title screen are both fine)or on my desktop (if i hover my cursor over an application like discord or spotify functionality returns). I dont think this is hardware related because my mouse works perfectly fine in other games, or when AC isnt running, and my pc has no problem maxing the game out graphically. This problem is new as of today; im about 8 hours into this save from two days of gameplay and before now everything has worked fine. Any help or sugestions would be greatly appreciated.
     2 people found this helpful
    Share this post

  2. #2
    Ubi-Baron's Avatar Ubisoft Support Staff EMEA
    Join Date
    Aug 2017
    Posts
    6,474
    Hi xXDEUS-VULTXx,

    The first thing I'd advise is verifying the game files, which will check for any missing or corrupt files and replace them. You can do this through the steps in the guide here.

    Are you using the Discord Overlay? If so can you try turning the overlay off, as this has been known to cause control issues.

    Thank you
    Share this post

  3. #3
    Hello, I am also having this problem and I can say that checking for files did not work for me. I personally dont use any kind of overlay either. I also tried to restart my PC, change the priority of the game on Task Manager, changing the graphics (At some point I thought it might be some sort of FPS related issue, but no it wasn't, I am also getting 60+ FPS on Ultra.) and at this point I just don't know what else it might be.
    Share this post

  4. #4
    I am also having this problem. I am running the game on my GTX 760 on the lowest settings possible. Even with a fps cap at 30, the game lags alot and the mouse input is slow.
    Share this post

  5. #5
    Ive tried both verifying game files as well as flat out reinstalling and no luck with either. Changing game priority in task manager was a no go as well.
    Share this post

  6. #6
    I'm also experiencing the same issue. It doesn't happen at start though. After some time of playing, the lag occurs. I have to restart the game to resolve it temporarily. Frames are good within the game and in other games.
    Share this post

  7. #7
    I have the same issue with mouse lag and it has nothing to do with discord over lay or verifying data files. This is a serious bug and it requires PC to be restarted each time it happens. I hope UBI will fix this ASAP.
    Share this post

  8. #8
    Anything from Ubisoft? Anyone aware of any fix?

    I can get around it with my Xbox controller but aiming and movement are much easier with M+K. Most of the time I still end up restarting the game. The issue happens randomly and at very inconvenient times - taking down a fort, fighting a merc, etc.

    Note: Even if you set the game to exclusive M+K setup, the mouse lag still occurs.
    Share this post

  9. #9
    I had the same issue, choppy camera movement but only with mouse. Keyboard and gamepad camera movements were smooth. So far only triggered near forts and bandit camps.

    Setting the game to Fullscreen instead of Borderless fixed it without needing to restart the game. Not sure if this will fix it permanently, just found this solution, needs further testing.
     3 people found this helpful
    Share this post

  10. #10
    Originally Posted by casteelzor Go to original post
    Setting the game to Fullscreen instead of Borderless fixed it without needing to restart the game. Not sure if this will fix it permanently, just found this solution, needs further testing.
    I had to test this out and I think it's been 40 or so minutes and I haven't encountered the mouse lag issue. Nice suggestion- hope it doesn't happen again.

    I'd really rather work with Borderless as it's easier to switch between monitors.
    Share this post