1. #241
    but when i connected to a tv crashes are still; this fixed by setting from 48 to192 khz sound in hdmi-nvidia sound card properties
    Share this post

  2. #242
    Still not working!
    Share this post

  3. #243

    Not able to open the link probably due to new ToS for google.

    I cant open the link, is there some other way to get it ?
     2 people found this helpful
    Share this post

  4. #244
    UbiDork's Avatar Ubisoft Support Staff
    Join Date
    Dec 2018
    Posts
    4,107
    thecrewubi1: Hi there! if you're still having this issue, please try these PC troubleshooting steps here! You may also want to try verifying your Uplay PC game files.
    Share this post

  5. #245

    Please Help

    Just subscribded to UPLAY+ and wanted to play some CREW2, but i was unable to play the game.

    The game starts and after i choose continue from the main menu, a black screen appears for abut 2 seconds and the game crashes/exits.

    Tried all the proposed fixes in the forums like running Uplay launcher and game as administrator, deleting TEMP files, verifying game files etc. but nothing works.

    Also i am not able to submit a support ticket.
    Share this post

  6. #246
    Running the game in Windows 8 compatibility mode fixed the issue for me.

    Removing BattlEye and verifying the files to have them reinstalled didn't fix the issue for me.
    Running the game as Administrator did not fix the issue for me.
     1 people found this helpful
    Share this post

  7. #247
    Running the game in Windows 8 compatibility mode indeed fixes the crashing issue, I'd like the devs to deal with this however, I'd rather not use any compatibility modes if it can be helped.
    Share this post

  8. #248
    Originally Posted by VooDooShamane Go to original post
    i have it now. it is working.
    here you go

    https://drive.google.com/file/d/1bRl...ew?usp=sharing
    Hello. The link is not working anymore so i cant fix The Crew 2. can anyone please send a new link with this file? i have heard it can fix your game and i really want to play it again. Thank you! :)
    Share this post

  9. #249

    I already found the solution in my case was to disable the anti virus "windows defender" since it corrupts uplay files
    Share this post