1. #1

    Major SFX failure in Arcade Editor

    Just ran into a problem with Far Cry 5's Arcade Editor. Spent 5 days on a glorious map, and suddenly ALL SPECIAL EFFECTS are no longer visible...? Muzzle flash, grenade explosions, blood ejections, smoke, fire, all of it has vanished from the map completely. No amount of saving, exploring, playing, brings any of it back. (Warning, sarcasm) I don't know if you knew this or not but you just can't play a Far Cry game without special effects (sprites, i suppose they're called).

    Anyone else have this problem, and OH GOD PLEASE tell me this will be fixed? I put so much time into this map... -_-
    Share this post

  2. #2
    Just had this happen to a map I've been working on. I've tried loading in single player, I've tried doing a hard reset on the Xbox, nothing works. Not sure if I added something in the map that could cause this but I'm at a complete loss here.

    EDIT: I went around my map and deleted a few dust effects, and that seems to have brought back all the other effects when testing my map. Not sure why that's happening though, I'm not even close to maxing out the MEMORY bar. Unless there's a SFX bar somewhere?
    Share this post

  3. #3
    Just an idea, but it could be that the Dunia engine itself has a limit on the number of sprites it can render at one time. If so, maybe they neglected to tie this in to the budget gauges.
    Share this post

  4. #4
    There is a VFX bar in the Budget Bar, but you probably have other budgets that are higher than it, so it is not displayed.
    But for your problem, it seems that if the VFX is filled to about 80%, then some other VFX will not appear when playing the map (it probably goes overbudget).
    So delete some of the VFX in the map and it should be all good.
    Share this post

  5. #5
    had this issue myself, though it only seems to happen when I place a VFX near a visually complex object. EG: I wanted to place mist coming from under a meshed walkway. The mist worked when I used it near solid ground but over a walkway or over water it didn't seem to respond.
    Share this post

  6. #6
    Share this post