Refresh rate cchanging doesn't work. If I change it to 60hz in options or even manualy in windows, the game still run on max (144hz for me)