1. #21
    Ubi-Mercury's Avatar Ubisoft Support Staff
    Join Date
    Oct 2020
    Posts
    47
    Hey outroduce, sorry to hear you're experiencing this issue as well. Could you please let me know if these troubleshooting steps help with this issue?
    Share this post

  2. #22
    Yeah, I had tried some of those steps. Clearing cache of Ubi Connect, reinstalling both Ubi Connect and the game, clearing windows registry keys related to Ubisoft, but it simply doesn't work, game refuses to run and throws an activation error.
    Share this post

  3. #23
    Go to your search bar, type 'vpn' access the pc settings. Disable the 2 vpn buttons.
    Share this post

  4. #24
    Ubi-Ginge's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    Posts
    2,987
    Hey outroduce!
    If you're still experiencing this, can you contact us directly in one of the following ways so we can look deeper into this -
    Our support site
    Facebook PM
    Twitter DM
    Share this post

  5. #25
    I have buy Far cry 5 but i got this issues too, help me pls
    Share this post

  6. #26
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    2,235
    Originally Posted by WuT_GoTeK Go to original post
    I have buy Far cry 5 but i got this issues too, help me pls
    Please make sure AFTER you have installed your game


    Go to https://ubisoftconnect.com/ and install the updated version of UBI CONNECT / Steam does not provide this with the game files on games that shipped more then 1 month ago as yes they do UPDATE UBI CONNECT QUITE OFTEN \and yes steam may install an out dated version with your game files .
    PLEASE see
    https://www.ubisoft.com/en-gb/help/c...t-pc/000063173
    ALWAYS WRITE DOWN THE E MAIL and password you use when creating any online account and store it in a safe place , your games will be bound to that account ..
    AND make sure you back up your save files MANUALLY if you have other ubi titles installed
    Please go here to see how to perform that step
    https://www.ubisoft.com/en-gb/help/c...iles/000063179
    or you can use a save game file manager program like this one
    https://www.gamesave-manager.com/
    Also ALWAYS run STEAM as well as UBI CONNECT and your game with ADMINISRATOR RIGHTS ENABLED
    see this page https://www.ubisoft.com/en-us/help/c...ghts/000060505


    verify your game files if you bought on STEAM
    see
    https://support.steampowered.com/kb_...2037-QEUH-3335

    if you bought it on on UBI CONNECT
    see
    https://www.ubisoft.com/en-us/help/c...t-pc/000060529


    ..as well as RESTART your PC , <(ALWAYS REBOOT)> relaunch STEAM and UBI Connect and try your game again.

    Additionally, for other issues you may wish to look into, that may be the cause of your problem ...


    Please see the Ubisoft Support Troubleshooting page here and please go through the steps provided
    https://www.ubisoft.com/en-gb/help/c...n-pc/000061047


    If you still have an issue, Please Contact Ubisoft Support Directly.
    you can do so from that above LINKED page .. or here...to open a support ticket / case
    https://support.ubi.com





    Good luck , i hope you find your fix!
    Share this post

  7. #27

    I may have found a fix

    I had the same issue and none of the tutorials or suggested help worked for me. I then proceeded to go on uplay and settings and unlinked my uplay to my steam. I then task managered everything that was associated with steam and uplay. I double clicked far cry 5 off the desktop icon and waited. Ubiosft/uplay then asked for my details and it loaded. I hope this helps
    Share this post

  8. #28
    Ubi-Swaggins's Avatar Ubisoft Support Staff
    Join Date
    Nov 2017
    Posts
    7,040
    Thanks for sharing your workarounds WID992007 and kie3000. Hopefully this resolves the issue for anyone who may encounter this in the future.
    Share this post