1. #1

    NAT type still strict

    Hi , i have a problem with NAT type Strict , i not supose to work fine after the Dedicated server start ? I still have problems with NAT Type . How i acces dedicated servers ? Is another client?
    Share this post

  2. #2
    Yeah, this is one of the things they promised when they announced the Dedicated Servers. Supposedly, after the update people wouldn't face any more connection problems due to NAT, because NAT would be irrelevant.

    But now people are facing yet other kinds of problems, and the NAT icon is still there, and we can't tell whether or not the NAT is still affecting our game because no one has a strict answer to that but the developers, and they are keeping their mouths shut.

    I have been facing issues with For Honor since launch day... More than a freaking year later, every single major update brings new issues that don't allow me to play. First came FPS drops, then memory leak, then black screens, then connection issues, now unfindable matches. Ubisoft support has the great tendency to ignore what you are saying and keep giving you standard messages that are not relatable to you even though you've already told them that.

    I'd like an answer about the NAT as well so the robots that reply to me in support can shut up about the port forwarding that we shouldn't even have to do in the first place, and freaking report the issue to the developers.

    EDIT: I forgot to reply to you some pointers. Sorry.

    By entering the game you are already accessing the dedicated servers. They game was updated on February 9 I believe, and the Dedicated Servers are already available for everyone else, no special client involved. The NAT still shows though, as mentioned above.
    Share this post

  3. #3
    ubi--unicorn's Avatar Ubisoft Support Staff
    Join Date
    Mar 2017
    Posts
    9,368
    Hey lupuemilian, these steps may help if you are experiencing connection issues. If that doesn't help, please let support know by creating a ticket with a screenshot of your forwarded ports.
    Share this post

  4. #4

    Really?

    You send me to Conection issues? You even read what i writed? My question is why i have NAT type problems on a dicated server?
    Share this post

  5. #5
    ubi--unicorn's Avatar Ubisoft Support Staff
    Join Date
    Mar 2017
    Posts
    9,368
    lupuemilian, NAT type is a connection issue! Those steps should help.
    Share this post

  6. #6

    Conection problems

    Its a conection problem , yes , but is a conection who can be resolved if i Port forwarding becouse if i dont i cant keep a host. But with dedicated server i should not need port forwardin becouse i dont need to host the server like other games. Then something is not ok with this "Dedicated servers "
    Share this post

  7. #7
    Lupuemilian,

    You won't find people who can/will answer your question on that. But I have spoken to the Ubisoft staff before and they confirmed one thing: NAT is irrelevant in PvP modes. So if you are playing any game mode in which there are only players, your NAT type will no longer make a difference, despite what it's showing in-game.
    However, NAT is still relevant for PvE game modes. So whenever you play a game mode that isn't Duel vs.AI, you'll be using the old peer-to-peer connection type. (Duel vs. AI happens on your computer)

    They haven't removed the NAT indicator from the game for some reason, most likely because it wasn't causing any trouble, but it does cause some confusion.
    Just like the "player activity" count, which shows the global activity, but not regional activity (which is the only one that matters now).

    Likewise, they have added regional restrictions that you cannot identify. So let's say you are in Asia. You won't be able to find players in the USA, because you are region-locked.
    It is not something they openly disclose, but they do mention it time to time. So if you are having difficulties finding matches it's likely that in your region there are not enough people playing your selected game mode at the time you are attempting.

    And they won't answer you on that, and Ubisoft web support is unprepared to handle your questions or issues on that.
    So that's probably the best you'll get for now.

    No point in making changes in your internet connection, unless there's actually something wrong with your connection (which you could identify by playing other games, or anything).
    Share this post

  8. #8
    Hey everyone,

    Not quite related, but I have found something that might allow you to change your NAT type.

    Before you go through the entire port-forwarding ♥♥♥♥♥♥♥t, there is a setting in Window's Network and Sharing Center which might be responsible for preventing your NAT turning green.

    Find the Networkd and Sharing Center on the Control Panel, and then look for the advanced options within it at the sidebar on the left. You'll see an option that goes along the lines of "let other people find my computer". Select it, or uncheck it, accordingly.

    I found this by looking for another Ubisoft game with NAT issues. Assassin's Creed IV: Black Flag:
    https://steamcommunity.com/app/24205...6703452031993/

    Good luck.
    Share this post

  9. #9
    Ubi-Rufus's Avatar Ubisoft Support Staff
    Join Date
    Apr 2016
    Posts
    995
    Hi everyone,

    NAT (Network address translation) is actually a process on your side where the router passes information from the public IP address (from the internet) to your local IP address. If you're connecting to the internet through a router then your NAT type will always be relevant.

    We would definitely suggest completing the steps Unicorn linked previously, these should help make sure you have the best connection possible to the game servers.
    Share this post

  10. #10
    Originally Posted by KabutoSoul Go to original post
    Hey everyone,

    Not quite related, but I have found something that might allow you to change your NAT type.

    Before you go through the entire port-forwarding ♥♥♥♥♥♥♥t, there is a setting in Window's Network and Sharing Center which might be responsible for preventing your NAT turning green.

    Find the Networkd and Sharing Center on the Control Panel, and then look for the advanced options within it at the sidebar on the left. You'll see an option that goes along the lines of "let other people find my computer". Select it, or uncheck it, accordingly.

    I found this by looking for another Ubisoft game with NAT issues. Assassin's Creed IV: Black Flag:
    https://steamcommunity.com/app/24205...6703452031993/

    Good luck.
    Hi, Ive looked everywhere in those lines and cant find the option, could you help me out?
    Are you using windows 7 for this?
    Perhaps you meant “Turn off network discovery” option? Is the one that resembles what you mean the most fron what I can find.

    Also, is this option in Home/Work or in public?
    Thanks for reading
    Share this post