1. #11
    No such luck itis just out of warranty so they say "we will ship it to tennesee and they will call you with what it will cost, plus I have to pay to ship whole heavy thing not just the pump. So figure even more expensive than a new one by the time im done, just another reason to shop elsewhere. 3 times this year junk from sears. 2 weedeaters 1 craftsman and 1 poulan and now this. craftsman used to be a name you could trust but now its junk except for the hand tools and small drills etc. All their power weedeaters, edgers etc are junk in my opinion.
    Next time I will try tractors supply or arrghhh Home depot.
    Share this post

  2. #12

    Stugumby, try Googling the problem, there's always someone with the same fault out there...

    I know sometimes Es next door to my workshop has the same problems with his PW and it is just a knackered lance...

    Best of luck...
    Share this post

  3. #13
    no it gets water flow with engine off, just not with engine on, it has no other user controls, just inlet hose and outlet and start engine/ pull trigger. It has a thermal relief valve that opens if it gets hot and its opening within 5 min since water isnt going thru all of the pump.

    pump is sold thru sears as an entire assembly, no internal parts kit etc. i saw a universal pump kit at lowes but i have no diagram etc for the inner workings so it will be a winter boredom project in dec before i mess with it again. thanks for the tips and suggestions.
    Share this post

  4. #14
    I rebuild alot of our pressure washers at work mainly because we have idiots running them.

    If you are getting water flow through the pump with just household water pressure and water will come out of the wand tip, there are basically 2 possible problems.

    #1 Check to make sure the pump has oil in the crankcase, not the engine powering the pressure washer. Make sure it looks clean and not cloudy if it's cloudy and has a milky look to it, your water seals are pooched, this will cause low pressure but not no pressure.

    #2 Check your unloader valve, it's the gizmo you turn to increase or decrease the pressure exiting the wand. If there is no pressure the unloader valve is plugged or buggered. The unloader valve is very similar to the needle valve that you used to adjust the mixture on a carburator, exact same thing needle valve, venturi, springs, ball bearings. .

    If you are careful you can take the unloader valve apart and keep the disasemble order so it's easy to slap back together. Clean the inlet, outlet, any orrifices you can see inside the valve body, it's brass or should be so it scratches easy, no harsh chemicals or solvents or you'll pit the inner surfaces. Use a dental pick carefully to remove any gunk, and a brass wire brush, just the toothbrush size is good.

    Look carefully at the needle on the valve if the tip isn't clean and nicely pointed it will need to be replaced but can be fixed if your careful, you can reshape the tip on a wire brush on a bench grinder, be gentle cause you only get one shot at it, reshape the tip to a nice conical shape approx. the size of the tip of a ball point pen. Slap it all back together and give it a whirl, if still not pressure there are a few other things you can try.

    If you thougth this was wordy there worse LOL, good luck with that.
    P.S Stay away from Craftsman power tool anything, **** poor quality and cheap materials. However there hand tools ie. wrenches ect. are fine.
    Share this post

  5. #15
    I saw this thread again and was wondering...
    What did you wind up doing about it?
    Share this post

  6. #16
    Very strange.
    I left a reply here this morning, and now it is gone.
    I was asking how you made out trying to fix this thing.

    Now this is weird. My original post from this morning (several hour ago) was NOT here. After I just left another post, it reappeared.
    How did this happen?
    Share this post

  7. #17
    T smoke, this thing adjusts pressure by changing the tips, ive tried all 3 and without the tip, there are no adjustments other than throttle speed, Oil is in the reservoir of the pump, it is still bluiesh black and dosnt seem to have any water/no icky yellow color to it.

    I have hand cycled by pulling the starter rope some CLR cleaner thru it about half a big bottle by pouring it into the inlet and hand pulling slowly so it comes out the outlet hose.

    For now its in the " i might work on it this winter" list. Havent found a diagram of the pump anywhere yet, sears has it under their parts sections as a complete assy, the only other pump parts you can get thru them is the inlet and outlet pipe and the relief valve that opens when it gets hot.
    Share this post

  8. #18


    Sun joe is one of the best brand in pressure washers so you can go for it .
    Share this post

  9. #19
    Thank you JasonEchols for the useful information.
    Share this post