1. #11

    Seriously Ubisoft

    So we are now in March and this bug still occurs. Really Ubisoft? This is a bug that occured for people 6months ago. You bunch of amateurs.

    Have some pride and fix it already.


    Originally Posted by nathan-esor Go to original post
    I'm currently stuck on the "Defend Caesar" portion of this mission where you shoot arrows at the oncoming enemies. Once the elephant crashes through, though, I was not able to kill it. After retrying a few times with no success, I had looked up a walkthrough how to get past this and realized that Bayek was supposed to swap to throwing spears soon after. I had tried again but he still did not switch to the spears. I demonstrate this in the video here.
    Share this post

  2. #12

    What the hell is going on?

    It's April now and people have been complaining for the last 6 months and still there is no patch? What kind of garbage support is this Ubisoft? I honestly demand a refund if you don't plan on fixing the game. I am facing the same issue that doesn't let me progress and the elephant keeps killing me, i've tried doing it for the past 30 mins and it wouldn't let me progress, especially when this is very close to the end of the game...This is SUPER frustrating...REFUND! NOW!
    Share this post

  3. #13
    ubi--unicorn's Avatar Ubisoft Support Staff
    Join Date
    Mar 2017
    Posts
    9,259
    Hey Proshifter, this issue has been fixed. If your game is up to date and you are still getting this issue, please provide us with videos and a screenshot of your version number in a ticket. Thanks!
    Share this post

  4. #14

    Thanks

    For some reason the quote button isn't working.

    I have filed a ticket, let's hope for the best & thanks for responding.
    Share this post

  5. #15
    I was having the same problem. For over an hour it would not switch to Spears. Then suddenly he did. All I did was hold the aim button down and the shoot arrow button. I aimed at the elephants face and never let off. Then he switched to Spears. I just spammed The throw button until the cut scene.
    I've never downloaded any updates to my game.
    Share this post

  6. #16
    Im stuck on the defend cesar portion of the battle of the nile mission. Attempeted to play threw just fine the first time . And now it wont give me any arrows or spears. Been trying everything i cam for over an hour and starting to get very angry wtf is going on....
    Share this post

  7. #17
    Ubi-Rufus's Avatar Ubisoft Support Staff
    Join Date
    Apr 2016
    Posts
    995
    Ryan.seamans could you check to see if your console and game has any updates pending?
    Share this post

  8. #18

    Battle of the Nile war elephant chase.

    I have been searching the interwebs for a solution and I found that in 2018 there's a glitch in this mission that pretty much makes it impossible to complete. I don't know If I have to uninstall the game or what. I read that there is an update to fix it but I still fail the mission. I dont even get the chance to try to defeat the elephant. As soon as it shows up, it tramples the chariot with no chance to defend Ceasar. Help? I am still searching for a solution. I love this game but it sucks that I have 50 hours and possibly have to start from scratch. I am playing on Xbox.
    Share this post

  9. #19

    Not fixed

    I'm still having the same issue, no spears appearing, just arrows, so I get crushed every single time.
    Share this post

  10. #20

    Answer

    I had this problem. The answer is to shoot the elephant constantly with arrows as soon as it comes out. This makes it take longer to catch up and if you keep doing this bayek will pull out spears
    Share this post