🛈 Announcement
Greetings! Anno forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Addon Activated Loop. Can't play Anno 2070

    I have a problem and don't know what to do next.

    1. When i start Anno 2070 tru my desktop as admin rights it starts up.
    2. Then i got the message "Addon activated" (see picture).

    3. As you can see i have only the option "REBOOT"
    4. When i click that the game starts up again and again the same message. every time i press REBOOT.
    I activated my key for the game as well on UPlay.

    Now what must or can i do.
    Share this post

  2. #2

    Fixed

    It seems that i have to buy and install Deep Ocean again.
    In order to fix that loop.
    Share this post

  3. #3
    Mr_B-'s Avatar Junior Member
    Join Date
    Apr 2015
    Posts
    14
    Not sure why nobody responded sooner to this. It's pretty much a known issue, and it seams UBI'soft isn't going to, or simply cant, fix it. The autopatcher freaks out, and fails the update. The solution is to replace it with an older one, run it manually, and then launch the game, which will trigger a CD key request for the original game, and after that everything will work as intended.
    I suspect you could use the autopatcher of the DVD, if you have those.

    More details, and link, here.
    Share this post

  4. #4
    Mr_B-'s Avatar Junior Member
    Join Date
    Apr 2015
    Posts
    14
    I cant believe this still isn't fixed yet. The last few days have had a major issue with the loginservers, and for what ever reason during those my game decided the deep ocean addon needed to be activated again. Since that wasn't possible, the game apparently removed it. And when it was possible to log back on to the servers, i got stuck in the activation loop again. Yey

    UBIsoft. Fix this already?
    Share this post

  5. #5

    same

    I have the same issue
    Share this post

  6. #6

    Found a fix for Anno 2070 reboot problem.

    I had the same problem. I used the autopatcher.exe file on my disc of Anno 2070 Deep Ocean, after a couple of small updates it allowed me to log in and play. I hope this is helpful
    Share this post

  7. #7
    Ok what the problem is that yes you own the add-on, but it isn't in the game inventory. When you go to install 2070. I try all the things that everybody has said that might work. You know like jumping through hoops.

    Well how I fix is I went to Ubisoft and bought the game again. Yes I know why but I sick of all this crap. It cost me $5 to fix it. When you go to install the game it will tell you it has to download about 6.02 gbs. After I bought it is now saying when you go to install the game now you have 6.38 gbs. So what is happening here yes you own it, but Ubisoft/Uplay never added it the your inventory.

    Plus this all started after the came out with 2205. Up to that point I have not had any problems. You might try to contact support to see if they can fix it by adding the game to your inventory. Plus make sure you have all your keys for both of them it make things go more smoothly.
    Share this post

  8. #8
    Share this post

  9. #9

    Still have problem

    https://support.ubi.com/en-GB/Faqs/0...ing-Deep-Ocean
    It doesnt work for me.. offline patcher give some error saying anno not installed, already update, and corrupted install
    I have steam version
     1 people found this helpful
    Share this post

  10. #10
    I just dont buy another Uplay Game, until they fix this, its so anoying.


    Download Patch manually
    http://static2.cdn.ubi.com/patches/a...tcher_2_00.zip
    But then you need to Enter the CD-Key,(i Saved mine), if you dont have try to repair or something...
    Share this post