1. #101
    Originally Posted by Jorrex. Go to original post
    Okay, I am pretty sure I covered each location and yet, no trophy popped for me.
    I have researched a bit and as it turns out, other players have encountered this as well.

    They claim it to be due to a certain action during the mission "Aya: Blade of the Goddess".
    When you complete a location while playing with Aya, you render this trophy unobtainable.

    Can someone confirm this, because if that's the case .. I need to restart the ENTIRE game.
    start from scratch and go through the whole deal again, grinding to lvl40 etc. to get every location and complete it.

    And hell no, I am in no mood for that! I'm 80+ hours in and nope, I don't want to go over this again.
    So please, someone tell me I'm not glitched ...

    Help me please! I'm one trophy away from the platinum and man, if I have to restart this whole game again, I'm about to snap!

    I can confirm that it looks like i've completed everything and I've been over the map multiple times, even with the brightness down so the ?s Show up better as well. I have not played Aya's mission blade of the goddess, I only ever remember playing Aya on a ship.

    If this glitch is the real deal I'll be gutted and don't think I'll even consider finishing the game.
    Share this post

  2. #102
    UbiMatcha's Avatar Ubisoft Support Staff
    Join Date
    May 2018
    Hey guys, sorry to hear you're still having trouble with this trophy.

    This issue has been reported as fixed, this post may help those still having trouble completing the trophy.

    Let us know if this hasn't helped the issue, thanks!
    Share this post

  3. #103
    I just completed the game, and have done all locations on the map. I have confirmed this by going over the map something like 30 times, and I've also tried with the filter of only uncompleted locations visible. I've also been to the bureau of the hidden ones after main quest completion.

    I've also been to the locations which don't unlock normally, like "Hotep Cavern", "Eesfet Oon-m'Aa Poo", "Dionysias Wharf", and "Abandoned Fishing Village".

    I've also completed all quests, and solved all papyrus locations, and anything else I could possibly think of, like turn down the brightness to 10%, and fine-comb the map something like 6 or 7 times while zoomed all the way in.

    Even after all that, the achievement did NOT unlock for me. I'm gutted.. I think this'll be my last assassin's creed game. I've always been a fan, and have played everything up until origins, but this is just a slap in the face.
    Share this post