1. #1

    Far Cry 4 Fails at Launch

    I have tried disabling all overlays, verifying files, running everything as admin and still no progress past the first window.

    SYSTEM INFO:

    Computer Information:
    Manufacturer: System manufacturer
    Model: System Product Name
    Form Factor: Desktop
    No Touch Input Detected

    Processor Information:
    CPU Vendor: AuthenticAMD
    CPU Brand: AMD Ryzen Threadripper 1950X 16-Core Processor
    CPU Family: 0x17
    CPU Model: 0x1
    CPU Stepping: 0x1
    CPU Type: 0x0
    Speed: 3400 Mhz
    32 logical processors
    16 physical processors
    HyperThreading: Supported
    FCMOV: Supported
    SSE2: Supported
    SSE3: Supported
    SSSE3: Supported
    SSE4a: Supported
    SSE41: Supported
    SSE42: Supported
    AES: Supported
    AVX: Supported
    CMPXCHG16B: Supported
    LAHF/SAHF: Supported
    PrefetchW: Supported

    Operating System Version:
    Windows 10 (64 bit)
    NTFS: Supported
    Crypto Provider Codes: Supported 311 0x0 0x0 0x0

    Video Card:
    Driver: NVIDIA TITAN Xp
    DirectX Driver Name: nvldumd.dll
    Driver Version: 22.21.13.8541
    DirectX Driver Version: 22.21.13.8541
    Driver Date: 8 21 2017
    OpenGL Version: 4.5
    Desktop Color Depth: 32 bits per pixel
    Monitor Refresh Rate: 60 Hz
    DirectX Card: NVIDIA TITAN Xp
    VendorID: 0x10de
    DeviceID: 0x1b02
    Revision: 0xa1
    Number of Monitors: 2
    Number of Logical Video Cards: 2
    No SLI or Crossfire Detected
    Primary Display Resolution: 2560 x 1440
    Desktop Resolution: 4480 x 1440
    Primary Display Size: 23.54" x 13.23" (26.97" diag)
    59.8cm x 33.6cm (68.5cm diag)
    Primary Bus: PCI Express 16x
    Primary VRAM: 12287 MB
    Supported MSAA Modes: 2x 4x 8x

    Sound card:
    Audio device: Speakers (Realtek High Definiti

    Memory:
    RAM: 32642 Mb

    Miscellaneous:
    UI Language: English
    Media Type: DVD
    Total Hard Disk Space Available: 5500385 Mb
    Largest Free Hard Disk Block: 2726326 Mb
    OS Install Date: Dec 31 1969
    Game Controller: Razer Orbweaver detected
    VR Headset: None detected
    Share this post

  2. #2
    Here is the error from Windows Event Viewer:

    Faulting application name: FarCry4.exe, version: 0.1.0.1, time stamp: 0x552190c2
    Faulting module name: FC64.dll, version: 0.1.0.1, time stamp: 0x5521908b
    Exception code: 0xc0000005
    Fault offset: 0x000000000002b5d9
    Faulting process id: 0x25c8
    Faulting application start time: 0x01d325446bfcfd2b
    Faulting application path: E:\Steam\steamapps\common\Far Cry 4\bin\FarCry4.exe
    Faulting module path: E:\Steam\steamapps\common\Far Cry 4\bin\FC64.dll
    Report Id: accd6f07-4aef-4a2b-896d-a3b02cdb7069
    Share this post

  3. #3
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    2,184
    ya try this yet ?

    open your Far Cry 4 folder

    find the bin folder and the games .exe right click it an set to run as Administrator right there

    save and exit

    next go to your far cry 4 game folder again

    find the folder marked SUPPORT \ SOFTWARE

    reinstall DX
    and VC Redist from that folder your .net framework may need to be updated too but win update can and should do that

    NEXT go to add remove Programs

    UNSTALL UPLAY (make sure its not open in task manger first at the time you remove it )

    go to the Uplay web page and DL and install the latest version of Uplay from here
    https://uplay.ubi.com

    MAKE SURE YOU INSTALL UPLAY TO THE SAME DRIVE AS WINDOWS ... this usually = Drive C

    yes your game can be on a different Drive ..but i think Uplay likes to be on the same drive as windows


    post back if this helps .. if not please contact Ubi Support Directly for your region

    you can find phone number\ support options \ and support hours information @ https://support.ubi.com/en-GB/Contact#en-gb


    PS .. good luck !
    Share this post

  4. #4
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    2,184
    the exception code your getting is an access violation error and yes they can be hard to troubleshoot

    use google as there are many ways you can troubleshoot your error see more here use google and type in
    Exception code: 0xc0000005

    http://www.errorlive.com/exception-code-0xc0000005

    see also https://social.technet.microsoft.com...itproappcompat


    see also https://compfreakstars.blogspot.com/...-day-many.html

    this is a common error and may be due to many things ....

    you can try also to run the Win 10 compatibility troubleshooter by right clicking on the games . exe file .. or set it to run in a win 7 mode and see if that helps

    but i'm betting you have either a bad uplay install or corrupt MS files installed and yes that error can happen alot with games
    Share this post

  5. #5
    I have just done all of what has been suggested, and I get the same error in Event Viewer and the application fails just after it is launched (I don't even get to the black screen). I believe I have to re-install my system because I have also been experiencing slow shutdowns and other windows quirks.

    Thanks for the help anyways.
    Share this post

  6. #6
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    2,184
    damn man that sucks
    you could avoid a reinstall

    try SF C scan now

    details are here to rule out bad system files
    https://support.microsoft.com/en-us/...rrupted-system

    might be faster then a reinstall especially with your Threadripper
    Share this post

  7. #7
    Found a solution. You have to turn on legacy mode in Ryzen Master, which disables one of the dies.

    I guess that Far cry 4 doesn't like all those threads.
    Share this post