1. #1

    Actions from Heroes VI unlocked in game but not in Uplay!!!

    I have started playing the Shadow of Darkness expansion for Heroes VI and I have unlocked 3 of the achievements in it, it shows up in the game even had the uplay popup in the game when I got them, but when I go in uplay they don't appear!! I don't have the "U" currency to buy stuff with and I don't have the EXP neither!!

    I have tried everythingn but I cannot see how to get Uplay to register my actions/achievements.....
    Share this post

  2. #2
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    21,061
    Hi YoshMaster, there is a list of achievements here http://mightandmagic.wikia.com/wiki/Achievement

    If they are still not showing, please contact our Support Team https://support.ubi.com so we can take a look.

    Thanks
    Share this post

  3. #3
    Same here, actions are not unlocking in Uplay, but works fine in game. Anyway to sync manually?
    Share this post

  4. #4
    Hi, sorry for my English and for the possible writing errors. I have the complete edition and the same thing happens to me.

    I have completed two actions, in the game they are reflected but in the uplay client they do not, Therefore I do not receive xp or u-points to redeem rewards.

    I have tried changing the language of the u-play client to English, in case this is a problem with the languages, I tried to change the language of the game using the HKEY register because in forums I read that it could synchronize the achievements but it has not worked for me. Finally I just sent a ticket to support, hopefully respond soon.

    If someone has solved the problem manually I would appreciate you commenting something.

    Greetings.
    Share this post

  5. #5
    Yes, it's still not working. Please fix it! It was the same for Trials Evolution this summer and you guys fixed it so please do the same for Heroes VI.
    Share this post