1. #11
    I tried the cable in my laptop again and it works fine. I disconnected the cable at the connector about 10" from the USB end and made sure it was clean and then just for kicks I pulled out my multimeter and tested the cable and there doesn't seem to be an open circuit in the cable.

    I'm running an 850 watt EVGA Supernova power supply that is less than 3 months old. Newegg's estimator puts my power draw at less than 650 watts at the moment (it claims 575, but it's not accounting for an h100i g2 liquid cooler, the case fans, and some led lighting so I'm estimating up by a very safe margin to account for them.)

    As for USB options in BIOS I'm given:
    Legacy USB Support
    Enable
    Disable (Currently on disable)
    Auto

    XHCI Hand-Off
    Enable
    Disable (Currently on disable)

    Single Port Control
    Enable or Disable individual USB ports, currently all set to Enable
    Share this post

  2. #12
    To resolve this issue I used a USB-C port on my computer and the rocksmith cable works every time I plug in it.

    Solution: USB-C to USB-A to the Rocksmith Cable. If you have a USB-C connection there is no need for a powered hub etc or messing with the BIOS settings.
    Share this post

  3. #13
    Looks like I was able to fix this after some more troubleshooting, for some reason in Windows 10 settings under "Microphone privacy settings" that "Allow apps to access your microphone" had been switched to off. Simply toggled this to on, fired up Rocksmith 2014 and was good to go.

    https://i.imgur.com/FKIbSBx.png
     2 people found this helpful
    Share this post

  4. #14
    You Sir, are my hero of today. Got my real-tone-cable finally working...
    Share this post

  5. #15

    Confirmed Fix after windows update 8-24-18

    This also fixed my issues after a recent windows update had turned the microphone setting off.

    @#$^Q%^#$#$ windows updates...
    Share this post

  6. #16
    UbiGabrinth's Avatar Ubisoft Support Staff
    Join Date
    Mar 2017
    Posts
    6,385
    I appreciate you sharing this fix, boltac. I'll make sure to suggest it if someone has troubles with their Real Tone Cable.
    Share this post

  7. #17

    None of these suggestions have solved the problem for me

    Like other users, I have the "hocksmit" / "USB Audio Device" issue when connecting my real-tone cable to my windows 10 computer.
    Occasionally I will get the cable to be recognized as a "Rocksmith Real-tone cable", but no matter what I do, I always get the error code 10 message that says that the device cannot start.

    I have tried the solutions offered above:
    - Real-tone cable into usb 2, usb 3, and usb 3.1 ports
    - Powered usb hub between computer (all ports) and real-tone cable
    - Usb C adapter onto real-tone cable, into usb C port on computer
    - Real-tone cable, through powered usb hub, into Usb C adapter, into usb C port on computer
    - altering BIOS to disable xhci for usb 3.0 ports
    - ensured microphone privacy settings were set to "allow"
    Scouring the net, there are heaps of other users reporting the same issues. In the Microsoft forums, it is suggested that the device is not supported, and that it's an issue with the manufacturer. On ubisoft forums, it is suggested that the real-tone cable uses generic usb audio drivers, and that there is nothing to be done on ubisoft's end.

    My cable works without issue on my older computer, and on my xbox, but I would really like to run Rocksmith on my new computer.
    Is there really no solution other than to go out and purchase an entirely new real-tone cable on the second-hand market, with a decent chance that I'll just end up with the same result?
     1 people found this helpful
    Share this post

  8. #18
    rcole_sooner's Avatar Moderator
    Join Date
    Mar 2009
    Location
    Norman, OK
    Posts
    13,765
    Even with error code 10, it should work.

    Have you tried it in the game?

    Have you tried disabling any microphone on your system?

    What other devices are connected to your system?
    Share this post

  9. #19

    Thanks

    After five hours full of stress you gave me the answer. Thanks.
    Share this post

  10. #20

    Took a while to figure out for me

    I'm sure everyone has different issues in this regard, but its worked fine on my MBP for years. Never on my desktop. Finally, based on one of the responses to one of these posts, I pulled the USB A to USB C dongle out of my smartphone box, and tried that... plugging the RT Cable into the USB C port... and viola. I can finally play RS without having to pull out my laptop and setup a table and play on the smaller 15" screen. Instead, I get to crawl under my desk on my hands and knees to hook a tiny USB C dongle to the back of my tower. Cheers.
    Share this post