Hello Warriors,

If you are having trouble launching the game, please try the following:

Possible Workaround 1:
- Run Uplay in Admin mode

Possible Workaround 2:
- Disable Anti-Virus software (BitDefender being a main offender here)or add the game and Uplay as an exception in your anti-virus software.

Possible Workaround 3:
- If you’re running on an Intel integrated chipset, try forcing the dedicated GPU instead:
- "Under the "manage 3d settings" tab in the nvidia control panel, you should be able to navigate to your game's .exe and specify which GPU to use from there.

Possible Workaround 4:
- Ensure the game is installed on your C: drive

Possible Workaround 5:
- Try launching the game from an entirely new Windows system profile:
- Windows 7
- Windows 8
- Windows 10

Possible Workaround 6:
- Try unplugging your controller/non-essential peripherals then launch the game again. Once this is done you should be able to reconnect your controller. Also temporarily disable any software linked to the controllers.

Possible Workaround 7:
-Consult the fixes provided in our EAC FAQ here!: https://support.ubi.com/en-GB/faqs/000025646

If the above doesn't resolve the issue can you please submit your logs to support?

Instructions to get the logs:
- Navigate to your Uplay installation directory (default: C:\Program Files (x86)\Ubisoft Game Launcher\)
- Select folder “logs”
- Submit all contained textfiles to Ubi Customer Support: https://support.ubi.com/en-GB