1. #1

    Myst III Exile on Windows 7 64-bit

    I have the 4-disk version of Myst III: Exile, and I have tried in vain to get it to run on Windows 7 64-bit. When I double click the .exe, the mouse gives me an hourglass, like the CPU's thinking about it, before it decides not to do anything at all. If I pull up Task Manager while executing it, the process pops up as "M3", stays for 1-2 seconds for disappearing. No pop-up, no splash screen, no nothing.

    What I have tried:
    *5 fresh installation attempts (2 typical installs, 3 full installs, none have worked)
    *Compatibility Mode set to pretty much every other version of Windows (I never expect this to do anything...). If I set it to run as administrator, the usual permission pop-up doesn't even show.
    *Installed the v.1.22 patch (did nothing)
    *Disabled (rather permanently) whatever security anti-virus came with the OS
    *A billion shutdowns and reboots (nope)
    *Executing from the first disk (nope)
    *Migrating all the files from the CDs to a flash drive, reconfiguring the drive setup, and executing (nope)
    *Virtual Machine with Windows 98SE (slightly better results here, the Exile splash screen appears before hanging indefinitely)
    *Downgrading, upgrading, and downgrading QuickTime several times (nope)
    *Last ditch to try to play the game... install it on my Mac. The graphics and sound refused to play nice, which is why I don't use Mac for any games.

    It sounds like a whacko hardware issue, but could it also just be an issue with 64-bit systems? I remember getting it to work with Vista years back. Oddly enough, after some doing... Riven runs beautifully, Myst IV: Revelation runs beautifully, but the third game just won't have it.
    Share this post

  2. #2

    Same issue

    I have the exact same issue on Windows 7 64 bit professional and the same results. Have looked EVERYWHERE and read every attempt at help - most are helpless. I WAS able to get the DVD version to run (had to copy the Data folder to my base drive so it would stop asking for the DVD) but the hand(mouse) pointer traces across the screen, I don't get any menu bar to save games or exit (so I have to end the game using Task Manager), and the screen control is not there so the visual field flies all over the place making play extremely difficult. Would much rather get the 4 cd set to run. If I find a way (not giving up) I will post an additional reply here. ANY help to we 64 bit Win 7 users would be enormously appreciated.
    Share this post

  3. #3
    TheBlade996's Avatar Junior Member
    Join Date
    Jul 2018

    Solution: Need to re-activate SafeDisc which Microsoft de-activated for Windows

    The problem you're encountering is because a security update from Microsoft in 2015 removed support from Windows Vista, 7, 8, and 8.1 for a copyright protection method called SafeDisc, which Myst Exile needs to start.

    If you're interested, there's the following great article on the site "How-To Geek" which gives more details:

    Rather than using NoCD patches or a utility called unSafeDIsc, any of which might contain viruses or other malware, How-to Geek gives a link to a Microsoft Support webpage which shows simple instructions to re-activate SafeDisc by yourself directly in the Command Prompt of Windows:

    Here are the steps I followed to re-activate SafeDisc in Windows 7 (**NOTE: The How-to-Geek article is missing ESSENTIAL Steps 3 and 11 below**):

    1) Open the Start menu, search for or type “Command", right-click the Command Prompt shortcut ("Invite de Commandes" in French) , and select Run as Administrator.

    2) Make sure the Command Prompt shows C:\Windows\system32>. If not, repeat step 1 as Administrator.

    3) Type: sc config secdrv start= demand

    (don't forget the space after the "=" sign)

    You should see a message that the ChangeServiceConfig was successful. For those who have never used a Command Prompt, remember to press Enter after each new command.

    **NOTE: You will get an error message at the next step if you don't type this command first**

    4) Type: sc start secdrv

    You should see a ten line message in table format showing "STATE: 4 RUNNING" on the third line.

    5) Close the command Prompt window.

    Now try starting Myst Exile from the desktop or start menu shortcuts and it should start normally! I'm now able to play it in Windows 7 without even using Compatibility Mode.

    When you're finished, you can do the following to deactivate SafeDisc:

    6) Run Command Prompt as Administrator (same as step 1 above) if not already running.

    7) Type: sc stop secdrv

    You should see a seven line message in table format showing "STATE: 1 STOPPED" on the third line.

    8) Type: sc config secdrv start= disabled

    (don't forget the space after the "=" sign)

    You should see a message that the ChangeServiceConfig was successful.

    NOTE: Microsoft recommends that you deactivate SafeDisc when you no longer require it to be running. According to Microsoft: "This workaround may make a computer or a network more vulnerable to attack by malicious users or by malicious software such as viruses." Nevertheless, I prefer this solution rather than running potentially dangerous patches or other programs with unknown content found on unsecure websites! At least this way, I know what instructions I'm giving my PC. And if it makes it possible to play this fantastic game again, I'm personally prepared to take this lesser risk!
    Share this post