1. #1

    MYST III Exile Windows 7 64 installation problems.

    I'm having problems trying to install Myst III exile, ( I have the four disk version) Everytime I install it. The game just won't play.
    Share this post

  2. #2
    In general,
    -- a. Install Exile to your C: drive.
    ----- 1. If you have a very small C: that's reserved for system files only, install Exile to D:.
    ----- 2. Do NOT install the game to an external drive, either USB or E-SATA.
    -- b. Start Exile from a fresh boot.
    ----- 1. Reboot, log into Windows with full Administrator privileges, and close all open applications. (Open the Control Panel, and select User Accounts. Your User Name should show Administrators under Group.)
    ----- 2. Disable all anti-virus/spyware/adware/pop-up programs running in the background.
    ----- 3. If you have only a software firewall (ZoneAlarm, for example), do NOT disable it!
    ----- 4. Do NOT run any other programs before starting Exile.
    -- c. Do NOT boot up with a CD or DVD in any drive.
    -- d. If the Exile disc autostarts when you insert it into the drive, cancel back to the Desktop.
    -- e. Start the game using the Exile icon on the Desktop, NOT the menu item on the Exile disc.


    Some questions:

    1. Do you get any error messages while installing Exile, and if so, what is the exact wording of the message(s)?

    2. How does Exile not play -- error messages, locked-up PC, blue screen, etc.?

    3. Is your PC a desktop or a laptop?

    4. Have you installed the latest Win 7 updates and Service Pack 1 (SP1)?

    5. Have you updated your video, sound, and mouse (or touchpad - mouse) drivers to the latest from your PC manufacturer or from your video chipset / sound chipset / mouse manufacturers?


    Pending answers to the above questions, some suggestions:

    1. Start Exile from a fresh boot, as above.

    2. Start Exile with the Run as administrator option enabled. (See How to Run a Program as an Administrator in Windows 7.)

    3. Run Exile in Program Compatibility mode. (See Windows 7: Compatibility Mode.)
    Share this post

  3. #3
    TheBlade996's Avatar Junior Member
    Join Date
    Jul 2018
    Posts
    3

    Solution: Need to re-activate SafeDisc which Microsoft de-activated for Windows

    The problem you're encountering is because a security update from Microsoft in 2015 removed support from Windows Vista, 7, 8, and 8.1 for a copyright protection method called SafeDisc, which Myst Exile needs to start.

    If you're interested, there's the following great article on the site "How-To Geek" which gives more details:
    howtogeek.com/230773/HOW-TO-PLAY-PC-GAMES-THAT-REQUIRE-SAFEDISC-OR-SECUROM-DRM-ON-WINDOWS-10-8.1-8-7-AND-VISTA/

    Rather than using NoCD patches or a utility called unSafeDIsc, any of which might contain viruses or other malware, How-to Geek gives a link to a Microsoft Support webpage which shows simple instructions to re-activate SafeDisc by yourself directly in the Command Prompt of Windows:

    Here are the steps I followed to re-activate SafeDisc in Windows 7 (**NOTE: The How-to-Geek article is missing ESSENTIAL Steps 3 and 11 below**):

    1) Open the Start menu, search for or type “Command", right-click the Command Prompt shortcut ("Invite de Commandes" in French) , and select Run as Administrator.

    2) Make sure the Command Prompt shows C:\Windows\system32>. If not, repeat step 1 as Administrator.

    3) Type: sc config secdrv start= demand

    (don't forget the space after the "=" sign)

    You should see a message that the ChangeServiceConfig was successful. For those who have never used a Command Prompt, remember to press Enter after each new command.

    **NOTE: You will get an error message at the next step if you don't type this command first**

    4) Type: sc start secdrv

    You should see a ten line message in table format showing "STATE: 4 RUNNING" on the third line.

    5) Close the command Prompt window.

    Now try starting Myst Exile from the desktop or start menu shortcuts and it should start normally! I'm now able to play it in Windows 7 without even using Compatibility Mode.

    When you're finished, you can do the following to deactivate SafeDisc:

    6) Run Command Prompt as Administrator (same as step 1 above) if not already running.

    7) Type: sc stop secdrv

    You should see a seven line message in table format showing "STATE: 1 STOPPED" on the third line.

    8) Type: sc config secdrv start= disabled

    (don't forget the space after the "=" sign)

    You should see a message that the ChangeServiceConfig was successful.

    NOTE: Microsoft recommends that you deactivate SafeDisc when you no longer require it to be running. According to Microsoft: "This workaround may make a computer or a network more vulnerable to attack by malicious users or by malicious software such as viruses." Nevertheless, I prefer this solution rather than running potentially dangerous patches or other programs with unknown content found on unsecure websites! At least this way, I know what instructions I'm giving my PC. And if it makes it possible to play this fantastic game again, I'm personally prepared to take this lesser risk!
    Share this post