1. #61
    Finally, UBISOFT heard us! http://forums.ubi.com/showthread.php...3#post12161413
    Update coming soon !
    Share this post

  2. #62

    First things first

    Originally Posted by TeltrasGaming Go to original post
    Finally, UBISOFT heard us! http://forums.ubi.com/showthread.php...3#post12161413
    Update coming soon !
    Chill, my friend.
    Fist we test the patch, then we celebrate
    Share this post

  3. #63
    Originally Posted by Wulvyr Go to original post
    I get terrible stuttering when I drive a car, otherwise the game works very smooth all the time, lowering the graphics doesnt help a BIT

    I got an 970 gt nvidia, I run every game at max so I never have troubles with different games , its always Ubisoft...


    So has anyone found a fix ? Is there a fix just like watch dogs 1 which had the identical problem and UBISOFT DIDNT DO ANYTHING ?

    waiting for a valid answer because im freaking out, AND YES i did a clean install of my drivers, I even formatted the whole PC
    not just that,
    I couldn't even load my game since update, I have the same graphic card as u r.
    This is awful
    Share this post

  4. #64
    Originally Posted by Wulvyr Go to original post
    I get terrible stuttering when I drive a car, otherwise the game works very smooth all the time, lowering the graphics doesnt help a BIT
    I got an 970 gt nvidia, I run every game at max so I never have troubles with different games , its always Ubisoft...
    3 Years ago, this guy posted the most annoying bug about this game. extreme stutter issues when entering a car.
    it's 2019 now and obviously no patch, update, new drivers, new windows updates fixed anything.
    i even read an hour now in all ubisfot forums and did not find a working solution.

    my specs are:

    i7 6700 K
    980 Ti
    16 GB Ram
    Win 10
    MSI Z97 Gaming 5 Mainboard

    i even tried setting the max. number of prerendered frames in the nvidia drivers, but only found the virtual pre rendered option anymore. newer drivers don't offer to select pre rendered frames anymore, just a new setting for turning pre rendered frames on or off at all and default is on already.

    after driving for about 10 seconds it gets smooth.

    in my opinion the game will buffer a lot more of the world because you will explore it faster while driving than when running, and that might be the big problem here.
    people reported it runs smoother when they install it on an SSD drive, that would make sense.

    if anyone out there found a fix to this problem after all, let me know.
    changing game config files didnt work for me and playing on ultra low settings is no option for me on a decent gaming rig (for that game).
    i am playing in 50 fps with very high settings, turning on framerate limiter to 50 doesnt fix the problem, changing Antialiasing from TXAA2 to off and SMAA off don't fix anything either.

    btw. turn on TXAA2 and use SMAA performance for edges, its the best choice for picture quality vs performance for me.
    Share this post

  5. #65
    Ubi-Woofer's Avatar Ubisoft Support Staff
    Join Date
    Aug 2019
    Posts
    1,067
    Hey there thexray, I am sorry to hear that you are experiencing performance issues in Watch_Dogs 2 when driving / entering a car.

    You've mentioned that it gets smoother after around ten seconds - by this do you mean that it is only for the first few seconds that the performance dips, and afterward it sorts itself?

    As ever, I would recommend completing our basic PC troubleshooting in the first instance, in particular disabling background applications and running both the game and Uplay PC with administrator rights, to try and improve your gameplay situation. Let me know if these steps make any difference.
    Share this post

Page 7 of 7 ◄◄  First ... 567