1. #1

    Far Cry 3 Blood Dragon - Never Started, not working.

    Hi all,

    I've never managed to have Far Cry 3 Blood Dragon starting at all. Looking through the forums I read I had to disinstall both the game and Uplay, so I did and reinstalled the lot but that didn't work either.
    If I click on the game's icon, it runs Uplay then flashes a DOS window then Uplay starts, a splash screen appears the vanishes and that's it.
    Pressing on "PLAY" just doesn't do anything apart from flashing a splash screen and the mentioned DOS window.

    Does anybody have any idea on what the problem could be ?

    Thank you !
    Share this post

  2. #2
    I have the same problem
    Share this post

  3. #3

    the same

    also, the same problem...
    Share this post

  4. #4
    UbiVertigo's Avatar Community Developer
    Join Date
    Oct 2015
    Posts
    1,427
    Hey all, please check the steps listed on this post. If that doesn't fix the issue for you, let me know.
    Share this post

  5. #5
    Originally Posted by UbiVertigo Go to original post
    Hey all, please check the steps listed on this post. If that doesn't fix the issue for you, let me know.
    Hello, I've tried the steps mention, but it didn't work :\
    Share this post

  6. #6
    Originally Posted by UbiVertigo Go to original post
    Hey all, please check the steps listed on this post. If that doesn't fix the issue for you, let me know.
    Hello.

    It's working now. Thanks a lot. Fix definately not easy to find.....

    Cheers
    Share this post

  7. #7
    UbiVertigo's Avatar Community Developer
    Join Date
    Oct 2015
    Posts
    1,427
    Originally Posted by sundark.ssh Go to original post
    Hello, I've tried the steps mention, but it didn't work :\
    Hey sundark.ssh - are you getting an error message, or is the game immediately shutting down when you try to launch it? I'm trying to make sure you're having the same issue.

    Originally Posted by sbaffini Go to original post
    Hello.

    It's working now. Thanks a lot. Fix definately not easy to find.....

    Cheers
    Glad it's working! Sorry that the info was hidden.
    Share this post

  8. #8
    Originally Posted by UbiVertigo Go to original post
    Hey sundark.ssh - are you getting an error message, or is the game immediately shutting down when you try to launch it? I'm trying to make sure you're having the same issue.
    What happens now is that the splash screen opens, but the game never starts.
    Share this post

  9. #9
    UbiVertigo's Avatar Community Developer
    Join Date
    Oct 2015
    Posts
    1,427
    Originally Posted by sundark.ssh Go to original post
    What happens now is that the splash screen opens, but the game never starts.
    Thanks sundark.ssh – Please contact our support team and let them know the issue and the steps you’ve taken. I recommend attaching your MSinfo file to the ticket.
    Share this post