1. #1

    [UPLAY] Watch_Dogs 2 doesn't even start

    I'm giving up !!!
    I tried everything I found on this forum (FAQs, other member suggestions) but the game refuses to launch.
    My problem? Pressing on the Play button in UPLAY will start the game. As soon as the preloding finishes, the game crashes... I've never even seen the splash screen with the Ubisoft logo.
    I did submit at least 4 times the report... but nothing seems to work.
    Is there any possibility that someone from Ubisoft can help me with this? (maybe sharing on this forum the collected info stored on my machine about the error)

    Thanks !!
    Share this post

  2. #2
    Ubi-Wedge's Avatar Ubisoft Support Staff EMEA
    Join Date
    Sep 2015
    Posts
    233
    Hey Gokussjin3,

    Can you let me know what kind of system specifications you have? Also what steps specifically have you tried from these forums so far?
    Share this post

  3. #3
    Hello :-)
    Thanks for the help.

    My specs are:
    Windows 10 Pro 64 bit
    Intel Core i7-4790 @ 3.60 GHz
    16 GB RAM DDR3
    NVIDIA GTX 770 2GB DDR5
    Asus Maximum VII Hero

    So... I tried the steps of this FAQ.
    I tried to add the "-eac_launcher" as a command line option.
    I tried to reinstall UPLAY.
    I tried to run UPLAY as Administrator.

    And I think that this is it.
    Share this post

  4. #4
    Ubi-Wedge's Avatar Ubisoft Support Staff EMEA
    Join Date
    Sep 2015
    Posts
    233
    Thanks for that info.

    If you could try verifying the game files, then possibly deleting your config file, found at Documents/"My Games"/"Watch_Dogs 2"/WD2_GamerProfile.xml, then try launching the game again.

    If you still get issues, then we would need your system reports sending to support, as detailed in the FAQ you ran through previously.
    Share this post

  5. #5
    So... I deleted the entire Documents/"My Games"/"Watch_Dogs 2" folder.
    I verified the game files.
    I then tried to start the game and the game is still silently crashing.

    Sending a report as suggested.
    Share this post

  6. #6

    it doesn't start the game

    I'm having the same problem, why buy a game that doesn't even start, i hope it gets a fix very soon or i do want my money to be refounded
    Share this post

  7. #7

    I played the game for a few hours without issues. Ever since the next time I tried launching the game, it would keep crashing or show the splash screen and crash silently. It just won't launch. I just built a brand new system with an i5-6600k and GTX 1070 and 16GB ram. I have uninstalled and re-installed Uplay and Watch Dogs 2 three times and still the same issue. How do we fix this?
    Share this post

  8. #8
    Please everyone, refer to this and this: removing the mirroring actually fixed my problem.

    We need a patch for this Ubisoft !!!!
     1 people found this helpful
    Share this post

  9. #9
    Same for me. Sometimes I get a popup saying application error with illegal memory reference, sometimes just silently crashing after the splash screen.

    I also tried every suggested solutions posted in this forum but none works.

    I submitted tickets 3 days ago with no response.

    Really frustrating wasting my time and money.

    I am definitely not buying anything from Ubisoft again.
    Share this post