🛈 Announcement
Greetings! Watch Dogs forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    City Hotspots/Geolocated new game bug with details

    First, this is not the "I can't find the 100th hotspot, plz halp!" 'bug' that is reported over and over again. (If you've come to this thread after a search and are missing one, try Farris Halstead Library in Parker Square which is often hard to see on the map or utilizing the City Hotspots App in your phone for listing of locations not yet visited.)

    My situation is this: on release of Watch Dogs my computer couldn't handle the game well, so I played a bit and shelved it. I dusted it off not long ago and gave it a modest playthrough before coming back for my 100% run which I tried to start yesterday. If things stay as they are, I fear I will not be able to achieve 100% in game or earn the Geolocated achievement, both of which are bugged because of multiple playthroughs. Let me explain from my experience in the hopes that someone here has a fix or suggestion or that Ubisoft may learn something that will help them fix the bug, unlikely that may be with the sequel on the horizon:

    Playthrough 1, May 2014: Stopped during Act 2, unlocked 19 City Hotspots (apparently, given the following)

    Playthrough 2, July 2016: Started new game, noticed several (19) City Hotspots were "grayed out" as having already been checked in and required the "E" interaction instead of middle mouse button. Checked in to a bunch all the same, and soon showed, via the Progression menu, that I had checked in to 80. Figured this included some of the E/second check-ins and didn't think anything of it. Waited to complete 100/100 for 100% playthrough to come.

    Playthrough 3, July 2016: Started new game, noticed that all but 1 City Hotspots were still grayed out and realized I would need to track visits to them on my own. Created spreadsheet of all 100 locations and began working through them. After checking in to the 8 spots in Parker Square (including the only non-grayed out one which earned me the Native Chicagoan in-game badge) I checked my progression only to find that it had only registered 1 spot, presumably the 1 of 8 that I had never previously checked in to.

    What this seems to prove is that tracking is completely broken, an odd mix of specific game tracking and account tracking, but in a way that they do not interact and therefore rob anyone who plays through the game more than once from being able to achieve 100%/earn the Geolocated achievement unless they do so in their first playthrough. Visiting spots for a second time do not count towards the 100 visits for either progression, meaning if you have visited them in an earlier playthrough they will never be counted again. My guess is this has something to do with earning Mayor being tied not to in-game but account check-ins, but this is an old problem and I hope it can be fixed.

    Here is additional info/image proof:
    Collectibles in-game progression map showing only 1/100
    In-game phone app showing 100/100 spots visited
    In-game badge, Native Chicagoan
    Map showing at least 26 grayed-out City Hotspots showing that 1/100 is far from accurate
    Uplay screenshot, lack of achievement earned.

    TL;DR: The in-game and Uplay achievements can only be earned by unlocking all 100 City Hotspots in a single playthrough and only if you are visiting them for the first time. Subsequent playthroughs therefore cannot achieve 100% and the Geolocated achievements are impossible to earn if starting a new game after visiting even a single location, even if visiting all 100 spots again.

    Anyone know how I might fix this? Reset my City Hotspots check ins? I'd settle for resetting my entire account history with Watch Dogs and starting a new game fresh if it meant being able to actually earn all achievements. Thank you for any help!
    Share this post

  2. #2
    Kevears's Avatar Member
    Join Date
    May 2014
    the Netherlands
    Hey Alyosha. That's a nasty issue. I recently started over as well on a new PC, while my progress was downloaded from the cloud, I wanted to just start the story over. I did not have this issue at all, so perhaps something went wrong when you installed the game. Have you tried verifying the game files in Uplay or, if that comes up clean, reinstalling the whole game?

    Else you might want to open a ticket at Support. I'm not sure if it can be done, but if it is possible, they are the ones who would be able to delete previous progress. Or perhaps they have seen this issue before and know something you can do to fix it.
    Share this post