1. #1
    Hi all,

    I've been away from IL-2 for awhile, and I'm no longer running the latest patch. The Game Updates link on the new website just links to a pic saying "Coming Soon." Where else can I find the patch for the latest version? Thanks!
    Share this post

  2. #2
    Hi all,

    I've been away from IL-2 for awhile, and I'm no longer running the latest patch. The Game Updates link on the new website just links to a pic saying "Coming Soon." Where else can I find the patch for the latest version? Thanks!
    Share this post

  3. #3
    Share this post

  4. #4
    Share this post

  5. #5
    Thanks fellas.
    Share this post

  6. #6
    LEXX_Luthor's Avatar Senior Member
    Join Date
    Apr 2003
    Location
    Ussia
    Posts
    8,815
    He/She needs 2.01 and 2.04 PATCHES right?
    Share this post

  7. #7
    Tully__'s Avatar Global Moderator
    Join Date
    Nov 2003
    Posts
    17,252
    <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by LEXX_Luthor:
    He/She needs 2.01 and 2.04 PATCHES right? <HR></BLOCKQUOTE>

    Only if he/she has FB and AEP. If FB only, the latest is 1.22
    Share this post