1. #1

    I'm waiting for the tall elk... and I"m waiting, and waiting and waiting.

    Hi guys.

    I'm stuck on the mission the huntress gives you to kill a tall elk. I've followed the fireflies and arrived at the spot and I've got the "wait for the tall elk" mission update, but nothing happens. The elk is actually just standing in the cave behind the waterfall but he never comes out. I waited all night, all the following day and into the next night. He's apparently stuck. If I attack him he ignores me.

    I've tried restarting the mission and the same thing happens.

    Any ideas?

    Thanks guys.
    Share this post

  2. #2
    Hey Mate,

    Same thing happened to me but with a small difference.

    I peppered the bastard with arrows and didn't get so much as a flinch from him. Then I decided to approach him and beat him with my club, but as I approached him, he decided to move: the bugger died pretty quickly after that.

    My guess is that I was standing too far away for it to trigger the action. I reckon you are too. Try approaching him and see what happens.
    Share this post

  3. #3
    Hey man! That's peculiar; I've never experienced that and I've done the mission 3-4 times.

    As MercurySpooning said, I think you may be too far away when you try to trigger the mission. What I do is follow the fireflies and then wait right inside the tiny mini-valley where the Tall Elk's cave is (about 100 ft away) then I eat the Food Boost that hides my scent. Then I started peppering him with arrows and tell my animal to attack him, and as he bucks up and kicks, pull out your spears and try to hit him as many times as you can. Should take a minute or two but it should take him down and be sure to stay out of its way....they are one of the few animals that are easy to avoid while charging but they can still kill you if you get too close and don't heal often.

    Try it out and let us know if it worked! If it didn't, I would consider recording it and sending it to Ubi.

    Edit: One time I set up a couple traps right outside the cave and when the he came out he triggered the traps and went NUTS. Maybe that'll kick start it into moving? Not sure, but thought it would be worth a try.
    Share this post

  4. #4
    This happened to me once, and I just killed it from a distance while he just stood there stupidly not moving in the cave. Made it easy to loot before the Udam showed up.
    Share this post

  5. #5
    Thanks guys. When I tried again today it worked first time. So all good.
    Share this post

  6. #6
    When I did this mission long ago the first time it worked as it should, but when I did it last week on survivor mode he just stood in the cave. From the last time I knew it shouldn't take him very long to come out, so just moved in closer and closer. Saw him in the cave and was able to drop him in the cave, and he never moved the whole time. The Udam never even showed up.
    Share this post

  7. #7
    The Udam have to travel to get to the cave where the Tall Elk walks out, and they are the ones that start the next part of the quest and the chase after the Elk. My guess is that what happens is random wildlife or Izila fight the Udam which keeps them from getting to the cave entrance. To fix this you have to abandon the quest and sleep in the near by camp, then start it again. But the easier way is to just beat the Elk to death with your club and skin him to end the quest.
    Share this post

  8. #8
    Had this happen to me as well. The quest worked fine on my initial playthrough, but this time no such luck.

    Either's it's caused by Survivor Mode or Ubisoft simply broke the quest recently for any gamemode.
    Considering their track record, I don't reckon this quest will be fixed soon if at all so thank god it's not as gamebreaking as some of the other bugs, like the already-lit-bonfire bug in the final Udam mission that prevents players from completing the game or beasts constantly dying randomly and thus royally screwing over Survivor Mode+Permadeath players.
    Share this post

  9. #9
    This happened to me last night, while playing in Survivor mode. Had to restart the game to re-do the mission. Simply restarting the mission did not solve the problem.

    I have played this mission in Survivor mode before, with no problem. So, what did I do differently this time, that may have messed things up? While on the firefly trail, I stopped to do a few other things, like picking up some wood, and trying to kill a deer. Also, when I reached the point where instructed to wait for the tall elk, I ran down into the cave to try to kill him quickly.

    After restarting the entire game, I stayed on the firefly trail, and did not make any efforts to do other things. When instructed to wait for the elk, I didn't budge...and out he came.

    Just guessing here, but I wonder if this mission is so linear, that taking extra actions stops it from working correctly.
    Share this post

  10. #10


    I just killed it straightforward got bored and issue an attack order for my saber tooth
    Share this post