🛈 Announcement
Greetings! Anno forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    "The activation key is already being used by another user"

    Hi, As per the title. I recently reinstalled ANNO 2070 via Steam. It asked me to link my Steam account to my Uplay account, which I did. The game is in both my Steam library and Uplay library (Bought via Steam).When I launch the game, it will attempt to login, then prompts me with a screen asking for my CD key. So I paste it from my Steam account and then says "The activation key is already being used by another user". This is correct, as the key is registered with me...I've never had any issues playing this game in the past.Has anyone had similar issues? I've tried searching but nothing seems to come up.
    Share this post

  2. #2
    UbiVertigo's Avatar Community Developer
    Join Date
    Oct 2015
    Posts
    1,445
    Hi Mart2912,

    Be on the lookout for a PM from me.
    Share this post

  3. #3

    Request a PM as well

    Originally Posted by UbiVertigo Go to original post
    Hi Mart2912,

    Be on the lookout for a PM from me.
    Hello

    I have the same problem as Mart2912 had, only I didn't go through STEAM, I simply installed from the CD, it then did all the patches and updates, asked me to sign up for uPlay, which I did, asked for the activation key, which I gave it, told me that the key was now associated with my uplay account. went to start the game and got the same thing Mart2912 got.

    Can I get what ever advice you PM'd Mart2912 as well please?

    Thanks

    Stephen.
     1 people found this helpful
    Share this post

  4. #4

    The same issue

    Hi, I've got the same issue with my Steam and uPlay accounts. Cannot get the game activated.
    Could somebody please help?
    Share this post

  5. #5
    If it is your Steam and Uplay account it shouldn't be asking for a key in the 1st place. I had the loop problem with mine and had to do the off line patch to get it to work.

    The one thing I'm going to ask is are you guys using the same user & password that you use here. Ubisoft uses the same User & password for everything. If you are using different user & password.

    That could be the problem. I use the same user & password for 1404, 2070, 2205, Ubisoft & Uplay. Once you setup the user & password I could be wrong but I don't think you change the user.
    Share this post

  6. #6
    dmdilks, thanks for your reply.
    Well, actually, I changed my username once - it was in some format like shopXXXXXXXX, and I changed it a long time ago to something more appropriate - 'verylazypanda'
    So this actually might be the problem, cause when I try to login to anno it pre-populates the login field with my old account name shopXXXXXXXX. And when I enter the serial it tells me it linked to some other accoun already.
    But when i try to log in with my new user name, Anno just wouldn't let me in - 'username/password incorrect'

    You mentioned, you applied some offline patch, could you please be more specific on it? What was the patch, and where to download it?
    Share this post

  7. #7
    That could be it you might have to email support. Tell them what you did and see if they can fix for you. Tell the everything and put the key with the old user name. The more info you give them the better they will understand what is going on. I don't know how long it will take. I had a problem with the post count here and it take them almost a week to get back to me.

    Plus most on line gaming site like Ubisoft really don't like you changing the user name. Here is the off line patch it is here with this thread. http://forums.ubi.com/showthread.php...ep-Ocean-addon.

    It might not help you because this had something to do with the add-on.
    Share this post

  8. #8
    Hey, thanks a lot for this. I dropped a mail to the support team, with the details of the case.
    Hope they will help me with this.

    Though, I must say, I'm feeling a little annoyed with the situation, you know.
    Share this post

  9. #9
    Originally Posted by Mart2912 Go to original post
    Hi, As per the title. I recently reinstalled ANNO 2070 via Steam. It asked me to link my Steam account to my Uplay account, which I did. The game is in both my Steam library and Uplay library (Bought via Steam).When I launch the game, it will attempt to login, then prompts me with a screen asking for my CD key. So I paste it from my Steam account and then says "The activation key is already being used by another user". This is correct, as the key is registered with me...I've never had any issues playing this game in the past.Has anyone had similar issues? I've tried searching but nothing seems to come up.
    I am having this same issue. HELP!
    Share this post

  10. #10
    Originally Posted by UbiVertigo Go to original post
    Hi Mart2912,

    Be on the lookout for a PM from me.
    I could really use your help as well. I have the same problem. Haven't played it in awhile, and have it on both UPlay and Steam as the OP does, and it gives me the same issue.
    Share this post