1. #1

    Game crashes when trying to access Video Settings

    Hi all,

    I recently received Far Cry 4 as a birthday gift, a little something to tide me over until Far Cry 5 arrived. I downloaded and installed it with no problem, then clicked Play. Ths is where it gets weird.

    The game opens in a tiny window. Like maybe 5 pixels high, at the most, and only the length of the minimize, full screen and close buttons put together. Pressing Alt + Enter expands the window to what I think is 1920 x 1080 resolution, still windowed. It won't go full screen, but at least it's windowed. Once presented with the "Press any key to continue" option, when i press a key it resorts to the tiny window again.

    Once I've alt+Entered up to the bigger window and get to the main menu i try to go into Video settings and upon clicking it, it crashes immediately and takes me back to the desktop and the UPlay Far Cry 4 game screen. This happens regardless of where I opened the game from.

    I have updated windows as far as I can (I'm running Windows 10 Pro), updated my graphics driver to version 390.65 (I have an Nvidia GeForce 1060 GTX). My PC exceeds all PC requirements even for max settings, and I've followed as many "attempted fixes" as I can find in the forums including re-installs, verifying files, manually altering my config file, disabling background programs, removing my graphics driver with DDU and then re-installing without GeForce Experience of ShadowPlay, running in compatibility mode for Win7 and Win8, running the Win10 troubleshooter, running in Admin mode, disabling DPI etc...

    I'd just really like to give it a go. Anyone have any ideas? I'm on the verge of re-installing windows back to version 1703 - pre Fall Creators update, just in case, but if anyone can fix it before this I'd be hugely grateful!

    Thanks
     4 people found this helpful
    Share this post

  2. #2
    UbiMorning's Avatar Community Representative
    Join Date
    Sep 2017
    Posts
    15,019
    Hey there! Since you've tried the recommended troubleshooting, we strongly encourage you to make a support ticket with your MSINFO and dxdiag files. These files will help us determine possible causes of your crash issues. Hope this helps
    Share this post

  3. #3
    Originally Posted by UbiSailorScout Go to original post
    Hey there! Since you've tried the recommended troubleshooting, we strongly encourage you to make a support ticket with your MSINFO and dxdiag files. These files will help us determine possible causes of your crash issues. Hope this helps
    I did over a week ago and have still heard nothing back at all - it's still in my support dashboard as "NEW".

    On Sunday night I did a full clean re-install of WIndows 10 Pro (version 1703 - pre-Fall Creators update), then installed a slightly older graphics card driver, and it's now working. Was hoping not to have to resort to something so drastic, but after such a resounding lack of communication I lost patience. I guess this can be closed. I'll keep an eye on updates in the future and let you know if one of them in particular is breaking the game.
    Share this post

  4. #4
    I just bought the game and I have exactly the same problem. Is there any progress on this issue on Ubisoft side or will I have to resort to the drastic solution above as well?

    Thank you.
    Share this post

  5. #5
    I have exactly the same problem. Is there any progress on this issue on Ubisoft side or will I have to resort to the drastic solution above as well?
    Share this post

  6. #6
    having the exact same problems .. any update on it?
    Share this post

  7. #7
    If you guys havent found a solution yet, try the below. It worked for me!

    I actually found it while looking for a solution to change resolution for Ghost recon Wildlands.

    Set you windows resolution to 1280x720, then boot up far cry 4 and go into video settings, set it to your desired resolution / full screen mode.

    Then alt tab to windows and change resolution back to your original setting.... et voila
    Share this post