1. #1

    Language selection bug in uplay

    I bought a physical copy in Hungary, thus my game is Hungarian by default. Tried to set the language back to English (due to the quality of the translation), but the game just doesn't change the language. I have the latest update for both the uplay client and the game. Any ideas? Thanks!
    Share this post

  2. #2
    LukaOo's Avatar Junior Member
    Join Date
    Aug 2013
    I have similar problem. I tried to install the game on two PC.
    1. During installation I got request to select additional language, and I had chosen Russian as second one. In first time The game was launched with English interface and sounds, then I changed video settings and start the game again. Then the game was launched with Russian interface.
    2. During installation I couldn't select a language at all, the installer did not show me the Language Selection window.As result, the game was installed with default language of OS.
    Share this post

  3. #3

    I need Hungarian language in the Collector Edition

    I bought pre order Collector Edition, but i not found Hungarian language
    Share this post