1. #1

    (PC) The game crashes witha black screen everytime I try to launch it

    So I just got the game but sadly everytime I try to launch it, it crashes. It doesn't launch Uplay for some reason, even though I installed Uplay beforehand, it just launches a black screen that instantly crashes.
    Share this post

  2. #2
    Hi rabbid!

    Could you please open a ticket with Technical Support, including a DxDiag report and MS Info to https://support.ubi.com so that they can investigate this for you? It will help us pin point the issue better.

    Thanks!
    Share this post

  3. #3
    Sure! I'll do it right away. Hope this can be fixed, game looks great fun.

    Also does the game come with an activation Uplay key? Because mine did not come with one so I can't try the uplay version.
    Share this post

  4. #4
    It should prompt you at start to log into Uplay so that you can continue to earn rewards.
    Share this post

  5. #5
    Well that's certainly strange. As when I launch the game it doesn't launch Uplay, I added that information to the ticket in case it is necesary. This is the first time I'm having a problem like this, hope it has a solution!
    Share this post

  6. #6
    RabbidB2, I'm experiencing the same exact issue. I have done some advanced debugging on this and am working on submitting a detailed bug report with my findings.

    I thought I'd ask you though as I have a strong suspicion on what the issue could be--what CPU does your machine have? Or if anyone else is experiencing this, can you reply with the same? Thanks!
    Share this post

  7. #7
    Originally Posted by lethargy86 Go to original post
    RabbidB2, I'm experiencing the same exact issue. I have done some advanced debugging on this and am working on submitting a detailed bug report with my findings.

    I thought I'd ask you though as I have a strong suspicion on what the issue could be--what CPU does your machine have? Or if anyone else is experiencing this, can you reply with the same? Thanks!
    I have an old AMD Athlon II X2 3,10Ghz one (2 Cores). I understand the game has 4 in minimun, but it doesnt state anywhere that it doesnt work on 2 cores. I've played games that required 4 cores minimun, like Metal Gear Solid V: Ground Zeroes perfectly and without an issue, even Witcher 3 (with the optimization mod). So I don't know what might be causing the issue, as the problem is that the game itselft doesn't launch Uplay.
    Share this post

  8. #8
    Originally Posted by RabbidB2 Go to original post
    I have an old AMD Athlon II X2 3,10Ghz one (2 Cores). I understand the game has 4 in minimun, but it doesnt state anywhere that it doesnt work on 2 cores. I've played games that required 4 cores minimun, like Metal Gear Solid V: Ground Zeroes perfectly and without an issue, even Witcher 3 (with the optimization mod). So I don't know what might be causing the issue, as the problem is that the game itselft doesn't launch Uplay.
    Yep, I've got an Intel Core2 Duo E8400 on mine. Pretty sure that's the issue. Still, I'm very surprised that they wouldn't simply catch this exception or check for this condition and display a helpful error message.

    Mods, please add this to the known issues sticky, perhaps?
    Share this post

  9. #9
    Yea, this should be on the issues sticky. I am still surprised that the game doesnt even launch Uplay if you don't have a 4 cores CPU. I doubt the game really requires a 4-core CPU to run, as mine has 6Ghz of power, wich is enough to play new games. Aaanyways the game is an Xbox port again so... We'll just have to wait for an official response from the devs.
    Share this post

  10. #10
    Hi all,

    If you are experiencing game crashes or black screens on PC, we suggest trying this workaround:
    - Have Uplay running and log in.
    - Launch Toy Soldiers: War Chest from the Uplay app.
    - You should then see the “Linking to Uplay” request on Uplay.
    - After the game is linked you should be able to launch the game normally with no crashes

    If you continue to experience issues, the best thing to do is to contact support for further troubleshooting
    Share this post