1. #1

    ACU won't load

    So i have played ACU for a long time, when i installed Windows 10 it stoped working. tried to go back to Windows 8.1 but wont help, ACU just wont load i only come to the loadingscreen. someone help me pleas!!
    Share this post

  2. #2
    Locopells's Avatar Moderator
    Join Date
    Jan 2010
    Location
    United Kingdom
    Posts
    8,119
    Try disabling the Uplay overlay - seems to be the main source of problems in Win10
    Share this post

  3. #3
    Nope, dosent work
    Share this post

  4. #4
    Someone help pleas!!
    Share this post

  5. #5
    Originally Posted by SolliThePro Go to original post
    Someone help pleas!!
    Give us your full specs please. It sounds like a computer issue not game. When I first upgraded my computer basically broke because of some internal issue transferred to Win 10 and alot stopped working. It alerated me to system failure and having to replace parts. If there is some internal problem I can tell you how to try and narrow it down but first need some details. If you just upgraded and not a clean install that has also been known to cause issues.
    Share this post

  6. #6
    Nvidia gtx 770 2GB
    8GB ram
    Intel(R) Core(TM) i5-3570K CPU @3.40GHz
    ASUS MAXIMUS V GENE, Socket-1155
    And 2 SSD'S and one HDD. have windows on one of them and games on the second one. just installed Win 10 not a clean install
    Something else you need to know?
    Share this post

  7. #7
    Your specs and mine are fairly similar only difference is I have 16gb ram and an i7 4790 3.6 turbo'd to 4.0. Your system could have done what mine did, which was get borked when I tried to upgrade for the first time due to underlying issues. First is this the only game having issues? Second is anything about your system unstable? Even a minor thing could be an issue. For example I noticed that my startup time was very slow and could barely run anything due to a failing HDD. Is anything else slow or sluggish? And did you say that it worked fine before the upgrade?
    Share this post

  8. #8
    I think Jonathans theory could be right.
    When I upgraded my secondary PC to Windows 10 it had the same problem.
    It booted up fine a few times and then was indefinitely stuck in start repair loop which would freeze.

    Have you tried support?
    Share this post

  9. #9
    Its the only game as far as i know. black flag works fine and so do far cry 4.
    The startup is just fine, it goes prety quickly, faster than windows 8.1 so dont think its anything there, the pc itself seems okey... its just the game wont load more than the loading screen with the 4 assasins..
    And the pc never stops in a loop or anything like that.
    Share this post

  10. #10
    Have you tried support?
    Share this post