1. #41

    Patch 1.1 crashes game om NVIDIA Shield

    After upgrade to 1.1, the game crashes when trying to close the tutorial screen.
    I get shown the tutorial screen even when loading an existing game and having played the game for many hours
    before the patch.

    So it is impossible to play the game since the tutorial screen is shown both for a new game and loading an old game.

    Android 5.0.1, Nvidia Shield tablet.
    Share this post

  2. #42

    Bug with Lizards damage

    As u can see Lizard damage pretty strange and while shootion always taken 150 dmd (low bound)
    Share this post

  3. #43

    Update for iOS

    Downloaded 1.1.0 update for IOS. Unfortunately it does not seem to have solved the crash problem on IPad 2 mini. As bad as before.

    Share this post

  4. #44

    IOS 1.1 update did NOT fix crashes

    Downloaded the newly arrived update (IOS 1.1) yesterday and I still can't play the game. Crashes within 2 minutes every time.

    Very frustrated.

    Originally Posted by Ubi-Nox Go to original post
    Update 10/02

    The first patch of Heroes III – HD Edition should be available in the next few days.
    Check http://forums.ubi.com/showthread.php...tch?p=10570441 for more information


    Hello everybody,

    As you may know Heroes III - HD Edition is now officially released on Steam!

    Please use this thread to report any bug with the final version of the game.

    Do not hesitate to contact our Customer Support in order to open a ticket for your problem http://support.ubi.com/en-GB
    Share this post

  5. #45
    First I just wanted to say, Great job on the game and keeping it updated.

    The bug I would like to point out is with the Dimension Door Spell.

    The spell still works as desired, it allows you to teleport your hero a number of steps from your current location, but when running in a higher resolution (everyone I imagine) there is no way to know how far the max actually is from your hero. A simple fix would be to put a box overlay on the screen limiting the mouse to the eligible Dimension Door area.
    Share this post

  6. #46
    Hello !

    I'm a streamer and have 2 monitors, unfortunately when i going to play game, i can't move my mouse to the right side and i have to use the arrow because the mouse is on the second monitor and stop the game, of course i ticked full screen and play on the resolution 1920x1080. please fix fullscreen mode, i want move my mouse to the right side without the arrow on the keyboard due of problem 2 monitors.

    Best Regards
    Share this post

  7. #47

    Bunch of bugs

    Besides the crashing every few turns, other bugs I've noticed are as follows:
    Moats cause no damage
    You can not go into a castle after a battle---this always crashes
    Archangels can not reanimate themselves
    Attacking a ballista, first aid tent or ammo cart causes an error then crash
    Can't always cancel spells.
    No hero stats
    If you click the castle to recruit troops it definitely crashes.
    Range shooters will not always hand to hand attack in close proximity.

    Hope these get fixed. I love this game and its really unplayable due to all the crashing.
    Share this post

  8. #48

    Major bug with android version

    Hello and sorry for my bad english.

    I got the game before 2 days for the lenovo tablet a3500 and runs very good without crashes and other problems.But there is one BIG bug that trasforms the game broken and unplayable.Simply i can't attack when i have battles!My ranged units don't attack on the enemy unit with the double tap and it shows me the statistics of the enemy unit.Tha same wiith the melee units but with the ranged units happens ALWAYS!I don't want to push the button of auto-play because with that way i lose all the fun and the strategy of the battles.

    It's very frustrating to pay 10 euros for a game with such huge problem.Please do something because i just can't play the game!When do you intend to update it?Please respond.
    Share this post

  9. #49

    No video on Android tablet

    I'm running HOMM3HD on a Galaxy Tab. At startup, the music plays, but there is no video. The game responds to me tapping on the screen, and certain random items do show (I think they had to do with logging into UPlay). I've tried changing the screen settings but it hasn't helped. I also tried the old stand-bys: turn it off and turn it back on, and delete/reinstall the game.
    Share this post

  10. #50

    black screen from steam


    I've try everything, reinstall, patches, forums, but still, black screen, i have audio and all i see it's the cursor. Any help?
    Share this post