PDA

View Full Version : Assassin's Creed: Unity crashes on startup, unless I delete video settings files.



wildweb2011
01-15-2015, 11:15 PM
Ok - so I have found a 'workaround' to stop AC Unity crashing to desktop on launch, though UPlay.
One forum suggested to delete the ACU.ini and GFXSettings.ACU.xml files in the folder Assassin's Creed Unity, in My Documents.
This does mean, that I can get into the game, no problem. No save problems. But I have to re-select all in-game graphics options, every single time.

This is obviously not as bad as some are reporting (still), but a real pain!! As saving the graphics options is never straight forward. Probably an extrea 5 minutes of saving and going through the menu's selecting all the settings you want for the graphics card.

It usually starts the game in a default 'high' setting. This is playable but obviously not why I got a 300 graphics card for Christmas...

Is there a fix, ANYWHERE to effectively save the graphics settings without having to delete these files every time, to allow the game to start up?

Thanks - anyone. Appreciate your help. :nonchalance:

YazX_
01-16-2015, 12:17 AM
Either the game is unable to access the file to read those settings which can be solved by running the game as administrator or there is a graphics option that causes it to crash, if running the game as admin didnt solve the problem then please state your system specs and in-game graphics options so we can help you further.

Also, make sure to clean install/reinstall the latest drivers.

wildweb2011
01-16-2015, 11:28 PM
Thanks for advice - but I have done everything you say.
Please bare in mind, I have around 50 different games on my PC, many of which are UPlay based. Don't have any issue with any of the others.
I have latest drivers from NVIDIA, clean install (as always).
I have an i5 3570k @4.2GHz
8GB RAM
GTX 970 - MSI
Running at 1920 x 1080

I set everything to ultra in AC Unity, then reduce the AA to FXAA (as I find it sharper). Reduce the environment to Very High.
I take off Stretching, and take off V Synch (NVidia control panel set to adaptive).
Runs fine once set all graphics to those settings. But for some reason, it cannot start the game and 'import' those settings on start up.
I'm obviously not the only one.. as I found a workaround on the net. But it's a REAL pain, every time.

Is there something I'm missing?
Any more suggestions?

Thanks for your help. Really do appreciate it.



Either the game is unable to access the file to read those settings which can be solved by running the game as administrator or there is a graphics option that causes it to crash, if running the game as admin didnt solve the problem then please state your system specs and in-game graphics options so we can help you further.

Also, make sure to clean install/reinstall the latest drivers.

YazX_
01-17-2015, 12:25 AM
ok there is a way to know what exactly is causing the issue but it needs patience and trial and error, so far we know that the game starts on default settings, so the way is to change one setting at a time and restart the game, once it crashes then the last setting you changed is causing the issue, please try it out and report back whats causing it so we can investigate more.

ansan12
03-28-2015, 07:08 PM
Ok - so I have found a 'workaround' to stop AC Unity crashing to desktop on launch, though UPlay.
One forum suggested to delete the ACU.ini and GFXSettings.ACU.xml files in the folder Assassin's Creed Unity, in My Documents.
This does mean, that I can get into the game, no problem. No save problems. But I have to re-select all in-game graphics options, every single time.

This is obviously not as bad as some are reporting (still), but a real pain!! As saving the graphics options is never straight forward. Probably an extrea 5 minutes of saving and going through the menu's selecting all the settings you want for the graphics card.

It usually starts the game in a default 'high' setting. This is playable but obviously not why I got a 300 graphics card for Christmas...

Is there a fix, ANYWHERE to effectively save the graphics settings without having to delete these files every time, to allow the game to start up?

Thanks - anyone. Appreciate your help. :nonchalance:



I have this same problem. I bought this game yesterday and played for few hours then today when I started, it crashes. So I deleted those two document files and now working in the default settings.
Mine is
i7 5820k @3.8ghz
24GB RAM
2 TB HDD with 128ssd
GTX 980 SLI.

Ubisoft needs to find a way to solve it.

Anykeyer
03-30-2015, 09:24 AM
install latest nvidia driver

amyalice32
03-31-2015, 10:33 AM
thanks install latest nvidia driver