PDA

View Full Version : FPS Drops, help!



gtkoolaidsman
01-14-2015, 10:43 PM
For some reason even on low the game is running quite slowly and the fps seems to dip down every few second maybe it's just my cpu or something else who knows.

Specs:
AMD-FX 8350 8 core @ 4.0 GHz
16 GB of RAM
2 Sapphire HD 7870 GHz edition overclocked (Crossfired obviously)
1920x1080 Resolution

I assume that's all I really need to put down, but yeah if anyone could help me out maybe with a work around or even a suggestion on something that could be slowing the game down it would be greatly appreciated. Also thank you to anyone who helps me out.

Ansellbwoy
01-14-2015, 11:50 PM
Your specs seem fine. So the obvious questions are stuff like drivers up to date? Not overheating? Failing that im not sure, maybe report it to Ubisoft.

What i have noticed though, is the game seems to really favour Nvidia GPU's. I know you shouldnt have to with your hardware, but maybe try lowering resolution. Might help. might not.

Ryk_Feral
01-15-2015, 12:19 AM
It's an ongoing issue with many systems.
There's a bunch of threads spread about of things that have worked for some (bunch so it'd need to be searched through to find em).

But yeah, your system probably isn't the problem......even monster rigs are having that issue.

gtkoolaidsman
01-15-2015, 12:20 AM
Your specs seem fine. So the obvious questions are stuff like drivers up to date? Not overheating? Failing that im not sure, maybe report it to Ubisoft.

What i have noticed though, is the game seems to really favour Nvidia GPU's. I know you shouldnt have to with your hardware, but maybe try lowering resolution. Might help. might not.

Yeah everything is up to date and such and it's not overheating, I'll test the resolution hopefully that works

gtkoolaidsman
01-15-2015, 12:39 AM
So I changed the resolution of the game to 1280x720 and it is actually still running at about the same FPS so around 15 - 20. I think this is just poor optimization because for the hell of it I switched to 640x480 and still get around 20 fps. Not to mention neither of my graphics cards are going above 50% usage.

Ryk_Feral
01-15-2015, 01:28 AM
So I changed the resolution of the game to 1280x720 and it is actually still running at about the same FPS so around 15 - 20. I think this is just poor optimization because for the hell of it I switched to 640x480 and still get around 20 fps. Not to mention neither of my graphics cards are going above 50% usage.

Well, you've pretty much proven it's not your system.