PDA

View Full Version : How to get 60fps on Assassin's Creed Unity with GTX 970 and higher



Fatal-Feit
01-05-2015, 09:28 AM
1. Turn off the in-game VSync. Use the Nvidia Control Panel or D3DOverrider to force enable VSync and Triple Buffering.

2. Use the following settings

Res - 900p or 1080p

Environment - High or Very High
Textures - High
Shadows - High
Ambient - SSAO
AA - FXAA
Bloom - ON

3. Enjoy!

I'm running on a EVGA GTX 970 / FX 8350, neither are OCed, and I'm managing to get 50-60fps with said settings.

YazX_
01-05-2015, 02:00 PM
Hey, just want to point out that D3DOverrider doesnt support x64 games, only 32-bit, i'm not aware if any updated version has been released to do so, however, RadeonPro supports x64 games and can force triple buffering with V-Sync.

Wrath2Zero
01-05-2015, 08:05 PM
The game triple buffers anyway with V-Sync on. Ubisoft games do have issues sometimes with locking to 30fps and you might even need to alt, tab to enable triple buffer like in Black Flag.

Fatal-Feit
01-05-2015, 11:12 PM
Hey, just want to point out that D3DOverrider doesnt support x64 games, only 32-bit, i'm not aware if any updated version has been released to do so, however, RadeonPro supports x64 games and can force triple buffering with V-Sync.

Does RadeonPro work with Nvidia cards?

YazX_
01-05-2015, 11:14 PM
Does RadeonPro work with Nvidia cards?

Yes it does :) , but to be honest fatal, i agree with WrATHZero, triple buffering works fine with ACU V-Sync and no need to force it.

Fatal-Feit
01-05-2015, 11:33 PM
In that case, skip step 1!

Carch
01-06-2015, 01:56 AM
I think the Vsync thing is a red herring. It's those lower settings that are going to make the difference. I've tested in-game vsync vs control panel forced vsync, and found no difference.

With maximum settings (but using FXAA - other forms of AA cause graphical artifacts in some areas of the game) I have a stock i7-3770k, 8 GB RAM and a GTX 970, and I get 50-60 FPS pretty much everywhere, with dips to 45 in some crowd and indoor areas. I much prefer the improved visuals, especially soft shadows, to the 10 extra FPS. The game is super smooth for me. Ironically, patch 4 reduced my frame rates by about 10%.

Animator_Alex
01-06-2015, 02:42 AM
I just wanted to point out that I have a GTX 780 SC and I get 55-60FPS easily with everything on ultra except shadows turned to high and Anti Aliasing turned to FXAA.