View Full Version : Assassins Creed is crashing everytime at start up- what is wrong?

12-24-2014, 06:05 PM

Got my self a brand new comp setup last week, tried to install ACU 2 days ago, everything went well playing it until now

Everytime i start ACU it freeze just seconds in the intro of ubisoft where it is telling about save game.

I even tried to uninstall and install again but nothing works

It says it can't sync probably?

So what should i do? This was a free game bying a geforce 970 and im running with 4790 processor and ACU is installed on a SSD drive

You can see on my profile how far i am in the game on uplay

12-24-2014, 06:08 PM
Are you using a Nvidia graphics card? Try updating to the latest stable driver that was just released.

12-24-2014, 06:14 PM
Are you using a Nvidia graphics card? Try updating to the latest stable driver that was just released.

Yes i wrote i have a msi 970 geforce card, and i got ACU as free gift

Now after re installing the game after it's freezing during intro i get the message ACU.exe dosent' work back to windows 8.1, i see it is trying to load a patch but from there it's aborting. When i first orginally installed it i could get the patch yeastarday but not today.

Apparently i must have some kind of connection failure with uplay cloud server?

My last mission was at Notre Dame 3% into the game

12-25-2014, 09:18 AM
OK so i tried something different

1. I'll start up Uplay application signing in on my account

2. Inside my account i cliick on games on the top menu

3. Instead of clicking play im clicking on the first line below, overview i think

4.Then Ubisoft noticed something is wrong and reinstalled everything

5. After reinstalling i can access to ACU logo, then everything freeze i have to reboot again

6. When uplay is launching the game it says its trying to sync to someting

I don't think it's anything wrong at my end but at uplay cloud server

12-26-2014, 10:43 PM
Guess what

Now it is working to access to the game, so it must have been issues at Ubisoft end not mine?

The game was down for over 2 days with no connection to the Ubisoft server

Was kind of worried for a while it was my hardware had failure since it freezed during intro

12-27-2014, 08:01 PM
And today i couldn't access to the game

To make this week short

I could play for 2 days

Couldn't access 2 days

Could acces again 1 day

Now can't access again

So it's wrongatt ubisoft end not mine

12-28-2014, 12:09 AM

Ubisoft online services have no impact in launching the game, yah sometimes it might be something off or a bug which would crash the game, but you can start UPlay in offline mode and bypass all those services, and if the game is still crashing, then its something you need to investigate in your PC. so first try to start UPlay in offline mode and launch the game.

if its still crashing and since you were able to run the game sometimes and other times it would crash, i expect that there is some process running in the background which conflicts with the game and causes it to crash, so please try to close all background processes and services except windows core ones and try to launch the game, if it didnt work, then try these steps:


12-28-2014, 10:49 PM
Thanksfor advice

12-29-2014, 12:42 AM
You are very welcome and please let me know if you need further help :)