View Full Version : AC Unity fails to load - white screen

12-20-2014, 05:44 PM
Yesterday I tried to play Unity (PC version) for the second time, I tried it out hen I first got it a couple of weeks ago and it worked ok then.
Yesterday it did get through the menus OK, but then took an age to load (Firstly it had frozen with a loading message and music, took a while but did eventually load the game).
As the menus were loading OK, I changes the resolution from 4k, down to 1440p and the game ran fine.

Today it won't even load the menus.

Is there a way I can change the res before I launch it to see it that helps?

12-20-2014, 07:07 PM
I'm having the exact same problem, since release this game has run fine for me I'm using gtx 970 getting 40 fps maxed out game running smooth no problem, I installed the performance patch today and went to go test it to see if there was a difference, I get to the menu screen upon loading the game and it instantly crashes I've tried verifying files run in administrator with no luck, anyone know a fix to this would be greatly appreciated.