PDA

View Full Version : [PC] Uplay Overlay Not Working



TechiCanadian
12-19-2014, 09:10 PM
Hi there, My name is Byron.

I have a problem with the Uplay Overlay, when I do (Shift+F2) nothing happens, even when I click the in-game Uplay button nothing opens up.
I made sure i have no Software interfering, all my PC drivers are up to date. And i have tried to disable and re-enable the Overlay and still nothing.
I have search the web and tried everything. All i want to do is buy In-Game Money (Crew Credits).
Please someone help me with this.

Thank you for your time :)

-Byron (TechiCanadian)

Ubi-Leorthian
12-22-2014, 02:55 PM
Hello TechiCanadian,

Thank you for contacting us with your question. I just opened up a game and the overlay opened without issue for me when I pressed Shift + F2. I know that when Watch_Dogs was released, players of that game couldn't initially open their Uplay overlay if they had recording software (fraps, bandicam etc) running when they opened it, but they could start those programs after the game was already running and it would work fine. However I've not seen other users reporting this issue with The Crew though, so I'm uncertain what could be causing it for you.

I'd suggest you contact the Ubisoft Support team to see if they are aware of a solution. The support team have information on game-specific issues and technical details that forum moderators don't have. You can contact support through our ticket system's webform found by clicking on "My questions" on this page: https://support.ubi.com and then clicking "Ask a Question".

If you have any issues using the webform, or if you cannot access your account, you can contact support for assistance through their Facebook page (https://www.facebook.com/UbisoftSupport), Twitter account (https://twitter.com/UbisoftSupport) or by phone (https://support.ubi.com/en-us/FAQ.aspx?platformid=60&brandid=2030&productid=3888&faqid=kA030000000eiChCAI).

Exxoc
12-24-2014, 12:09 PM
We are in the same boat, just a few days ago the overlay was working fine but up untill recently it doesn't start. When launching The Crew the message telling me that I can press Shift-F2 to open doesn't appear like it normally would. I tried to press the Uplay buttons in the main menu but like you mentioned nothing happens. I as well have no other software running but Uplay itself, and no other overlay is interfering with it. It's like the game isn't compatible.

Ubi-Leorthian
12-24-2014, 01:35 PM
Just to check, you haven't accidentally turned off the option to use the overlay have you? If you go to the settings menu in your Uplay client (click on the gear icon in the top right then choose Settings) there is an option labelled "Enable in-game overlay for supported games". Is the box next to that options marked with tick? If not, make sure it is then click Save.

Exxoc
12-24-2014, 02:27 PM
I have disabled and enabled it, redownloaded Uplay and The Crew + verified it's files. Only thing I haven't done is test it on another of your games which I will once Unity has finished downloading.


Well, haven't changed anything since I wrote the above text, and now it works for both mentioned games. I don't know why or how come it was broke before but I guess you'll never understand these computers will you? :D

cobra272
03-10-2015, 06:35 PM
Funny when I press shift f2 in the crew the overlay opens up then game hangs, have to bring up task manager which says uplay running the crew not responding ever since version 5 fiasco. :confused:

K1R8YW1R8Y
11-11-2019, 01:40 PM
After disableling FRAPS from my computer and re-launching the game the uplay overlay worked as it did before.
Thank you for your help

Ubi-Viral
11-12-2019, 03:20 AM
After disableling FRAPS from my computer and re-launching the game the uplay overlay worked as it did before.
Thank you for your help

Awesome to hear that you managed to find a workaround!

LovelyMallard
02-22-2020, 09:29 AM
This is total bs. I have the same issue and I get login error 0x00000004 every time when I try to access ubisoft club from menu; shift + f2 does nothing. Also, the game crashes on your first splash screen if you have "send crash report" option in uplay client. I have no fraps, no MSI afterburner enabled, nothing and it doesn't work. Irritatingly enough, it worked fine six days ago.

I opened my support ticket almost five days ago and nobody even acknowledged the problem.

larrykop1967
02-25-2020, 12:03 AM
This is total bs. I have the same issue and I get login error 0x00000004 every time when I try to access ubisoft club from menu; shift + f2 does nothing. Also, the game crashes on your first splash screen if you have "send crash report" option in uplay client. I have no fraps, no MSI afterburner enabled, nothing and it doesn't work. Irritatingly enough, it worked fine six days ago.

I opened my support ticket almost five days ago and nobody even acknowledged the problem.

I'm having the exact same issue's as you, and my fps counter no longer work's, it seemed to happen when there was an update not so long ago, i have uninstalled and reinstalled uplay and it's still the same, it's def an issue with the client

Ubi-Woofer
02-25-2020, 09:09 AM
This is total bs. I have the same issue and I get login error 0x00000004 every time when I try to access ubisoft club from menu; shift + f2 does nothing. Also, the game crashes on your first splash screen if you have "send crash report" option in uplay client. I have no fraps, no MSI afterburner enabled, nothing and it doesn't work. Irritatingly enough, it worked fine six days ago.

I opened my support ticket almost five days ago and nobody even acknowledged the problem.

Hey LovelyMallard :) Have you performed connectivity troubleshooting for Uplay PC (https://support.ubi.com/en-GB/faqs/25657/Connectivity-Issues-with-Uplay-PC-UPC/), as well as performed a full reinstallation of the client from our website (https://support.ubi.com/en-gb/Faqs/000025799/Installing-or-reinstalling-Uplay-PC-UPC)?

Your support case currently is headlined as a missing action issue in the Ubisoft Club - can you clarify for me if the issue is that your actions are not unlocking, or as the title of this thread mentions, just that the Uplay PC overlay does not open? I can correct the topic of your case if the latter, so that it can be seen by the right team.


I'm having the exact same issue's as you, and my fps counter no longer work's, it seemed to happen when there was an update not so long ago, i have uninstalled and reinstalled uplay and it's still the same, it's def an issue with the client

Have you disabled all potentially conflicting background applications (https://support.ubi.com/en-GB/faqs/000025721), as well as run the client with administrator permissions (https://support.ubi.com/en-GB/faqs/000025662/Run-applications-with-administrator-rights)?

Please let me know any steps you have taken in addition to reinstalling the client to try and address this, so that I can submit a report for the issues if needed.

LovelyMallard
02-25-2020, 02:32 PM
I'm having the exact same issue's as you, and my fps counter no longer work's, it seemed to happen when there was an update not so long ago, i have uninstalled and reinstalled uplay and it's still the same, it's def an issue with the client


What are we gonna do about it? I don't think ubisoft gives a damn about this, hence their silence. I bought Odyssey (Gold Edition) and I am unable to finish it properly due to this annoyance: no screenshots, no fps counter, no overlay, no in-game chatting... To my horror I've seen that my other uplay games exhibit the same problem as Odyssey with ubisoft club.

Just want to finish Odyssey in peace and move on with my life.

Ubi-Woofer
02-25-2020, 02:55 PM
Did you catch my post above yours, LovelyMallard? :) I am keen to assist with this issue as best I can. I'll need to rule out some common issues / potential causes through troubleshooting first before reporting the issue further, however. I'll also need to understand your issue clearly - is it with the overlay specifically, as I asked before?

It would be useful if affected players (such as yourself!) could provide me with their Uplay PC launcher / overlay logs (https://support.ubi.com/en-GB/faqs/000033010) in a support case (https://support.ubisoft.com/Cases/New) as well. If the case reference numbers are left in this thread, I can take a look and see if there are any common errors reported.

larrykop1967
02-25-2020, 03:58 PM
Hey LovelyMallard :) Have you performed connectivity troubleshooting for Uplay PC (https://support.ubi.com/en-GB/faqs/25657/Connectivity-Issues-with-Uplay-PC-UPC/), as well as performed a full reinstallation of the client from our website (https://support.ubi.com/en-gb/Faqs/000025799/Installing-or-reinstalling-Uplay-PC-UPC)?

Your support case currently is headlined as a missing action issue in the Ubisoft Club - can you clarify for me if the issue is that your actions are not unlocking, or as the title of this thread mentions, just that the Uplay PC overlay does not open? I can correct the topic of your case if the latter, so that it can be seen by the right team.



Have you disabled all potentially conflicting background applications (https://support.ubi.com/en-GB/faqs/000025721), as well as run the client with administrator permissions (https://support.ubi.com/en-GB/faqs/000025662/Run-applications-with-administrator-rights)?

Please let me know any steps you have taken in addition to reinstalling the client to try and address this, so that I can submit a report for the issues if needed.

yes, i have done those steps, basically there was an update to uplay recently and my fps counter dissapeared and i have the issues that lovelymallard has, i had no problems before

larrykop1967
02-25-2020, 04:00 PM
What are we gonna do about it? I don't think ubisoft gives a damn about this, hence their silence. I bought Odyssey (Gold Edition) and I am unable to finish it properly due to this annoyance: no screenshots, no fps counter, no overlay, no in-game chatting... To my horror I've seen that my other uplay games exhibit the same problem as Odyssey with ubisoft club.

Just want to finish Odyssey in peace and move on with my life.

i don't know to be honest, i can still play Origin's and Odyssey, but without those thing's you mention, unless it's something to do with windows 7 i dual boot, but still use 7 mostly for my games,

LovelyMallard
02-25-2020, 05:07 PM
Did you catch my post above yours, LovelyMallard? :) I am keen to assist with this issue as best I can. I'll need to rule out some common issues / potential causes through troubleshooting first before reporting the issue further, however. I'll also need to understand your issue clearly - is it with the overlay specifically, as I asked before?

It would be useful if affected players (such as yourself!) could provide me with their Uplay PC launcher / overlay logs (https://support.ubi.com/en-GB/faqs/000033010) in a support case (https://support.ubisoft.com/Cases/New) as well. If the case reference numbers are left in this thread, I can take a look and see if there are any common errors reported.

Good day.

Firstly, I have tried a plethora of advises in hopes of fixing this issue. About dozen of them. Nothing helped.

Secondly, my problem is that uplay overlay stopped responding to both 'shift+F2' command and when I try using my mouse/gamepad to launch uplay club in game (store connects fine). As aforementioned, I get login service error 0x00000004, which means that neither my actions unlock, eg. when I finish an important quest(s) (get uplay points), nor do I get notified with achievements, eg. killed 'Steropes - The Lightning Bringer'.
Also, again, as I've wrote, I can't take screenshots, fps counter and similar; my overlay is enabled in uplay via options while in windows desktop (not while in the game - which is like I said not working).

Thirdly, I have made a support ticket (CASE NUMBER 10845086) and provided you with my dxdiag, msinfo document and a screenshot with the error window, and I will update you with uplay logs.

Lastly, I have no programs running in the background which are not recommended (fraps, MSI afterburner) and I run both the client and the game in the administrator mode.

Note: My steam overlay works fine, if that's something to worthy of noting.

LovelyMallard
02-25-2020, 05:12 PM
i don't know to be honest, i can still play Origin's and Odyssey, but without those thing's you mention, unless it's something to do with windows 7 i dual boot, but still use 7 mostly for my games,

No, I can run it too if I disable "send crash reports", but I want to be notified when I reach an in-game milestone, and I don't like playing while I have a broken service, which was working fine eight days ago.

apheXrush
02-25-2020, 05:29 PM
Hello there, having exact same problem with AC:O. https://forums.ubisoft.com/showthread.php/2190982-AC-Odyssey-Ubisoft-Club

I believe it started after latest uplay update like a week or so ago. Tried bunch of stuff, nothing helped, waiting for a next uplay update, but honestly I doubt it would be fixed.

LovelyMallard
02-27-2020, 01:37 AM
Fascinating. I have waited almost ten days to get a generic link https://support.ubisoft.com/en-GB/Faqs/000025947/Basic-PC-Troubleshooting as a fix. As if I haven't tried that already...

And it's not only Odyssey overlay that's not working. It's EVERY uplay game that doesn't have the overlay working!

Ubi-Woofer
02-27-2020, 09:49 AM
larrykop1967 - Would you be able to provide me with images showing that the FPS counter is missing, and also of the error message you are receiving when trying to access the Ubisoft Club? Also, you've mentioned using Windows 7 Dual Boot - have you tested Uplay PC / your games on your PC without using this function?

If you have not already done so, would you mind making a support case (https://support.ubisoft.com/Cases/New) on our website with your MSINFO (https://support.ubisoft.com/en-GB/faqs/21216/), DXDIAG (https://support.ubisoft.com/en-GB/faqs/21185/), Launcher Log and Overlay Log (https://support.ubi.com/en-GB/faqs/000033010) attached?

LovelyMallard - Thank you for opening a support case and submitting the requested documents. My colleagues (just as I have here) will run through basic troubleshooting with you in the first instance, and will need confirmation that you have completed everything we recommend. This is just standard process, to ensure that we are removing the likelihood of any common issues :) I'd like to recommend one additional step, which is to test both Uplay PC and Assassin's Creed: Odyssey on a new administrative user on your PC in a clean boot environment.

To create a new user, please follow the steps in this guide (https://support.microsoft.com/en-gb/help/13951/windows-create-user-account), then perform a clean boot using these steps (https://support.microsoft.com/en-gb/help/929135/how-to-perform-a-clean-boot-in-windows) here. I have noted many socket errors in your launcher log, as well as many error reports for Assassin's Creed: Odyssey in your MSINFO. It would be good to see if these issues persist across multiple user accounts, as such.

Please also do make sure to have forwarded the ports for both Uplay PC (https://support.ubi.com/en-GB/faqs/25657/Connectivity-Issues-with-Uplay-PC-UPC/) and Assassin's Creed: Odyssey (https://support.ubisoft.com/en-GB/faqs/000036875/), as this will help ensure traffic is not blocked and your connection to our servers can be more successful. One other recommended test would be to try a different internet connection, such as a mobile hotspot, to check whether you are able to access the overlay etc. using that.

apheXrush - Would you mind doing as I requested of LovelyMallard, to make a support case (https://support.ubisoft.com/Cases/New) on our website and attach your MSINFO (https://support.ubisoft.com/en-GB/faqs/21216/), DXDIAG (https://support.ubisoft.com/en-GB/faqs/21185/), Launcher Log and Overlay Log (https://support.ubi.com/en-GB/faqs/000033010)?

LovelyMallard
02-27-2020, 01:01 PM
larrykop1967 - Would you be able to provide me with images showing that the FPS counter is missing, and also of the error message you are receiving when trying to access the Ubisoft Club? Also, you've mentioned using Windows 7 Dual Boot - have you tested Uplay PC / your games on your PC without using this function?

If you have not already done so, would you mind making a support case (https://support.ubisoft.com/Cases/New) on our website with your MSINFO (https://support.ubisoft.com/en-GB/faqs/21216/), DXDIAG (https://support.ubisoft.com/en-GB/faqs/21185/), Launcher Log and Overlay Log (https://support.ubi.com/en-GB/faqs/000033010) attached?

LovelyMallard - Thank you for opening a support case and submitting the requested documents. My colleagues (just as I have here) will run through basic troubleshooting with you in the first instance, and will need confirmation that you have completed everything we recommend. This is just standard process, to ensure that we are removing the likelihood of any common issues :) I'd like to recommend one additional step, which is to test both Uplay PC and Assassin's Creed: Odyssey on a new administrative user on your PC in a clean boot environment.

To create a new user, please follow the steps in this guide (https://support.microsoft.com/en-gb/help/13951/windows-create-user-account), then perform a clean boot using these steps (https://support.microsoft.com/en-gb/help/929135/how-to-perform-a-clean-boot-in-windows) here. I have noted many socket errors in your launcher log, as well as many error reports for Assassin's Creed: Odyssey in your MSINFO. It would be good to see if these issues persist across multiple user accounts, as such.

Please also do make sure to have forwarded the ports for both Uplay PC (https://support.ubi.com/en-GB/faqs/25657/Connectivity-Issues-with-Uplay-PC-UPC/) and Assassin's Creed: Odyssey (https://support.ubisoft.com/en-GB/faqs/000036875/), as this will help ensure traffic is not blocked and your connection to our servers can be more successful. One other recommended test would be to try a different internet connection, such as a mobile hotspot, to check whether you are able to access the overlay etc. using that.

apheXrush - Would you mind doing as I requested of LovelyMallard, to make a support case (https://support.ubisoft.com/Cases/New) on our website and attach your MSINFO (https://support.ubisoft.com/en-GB/faqs/21216/), DXDIAG (https://support.ubisoft.com/en-GB/faqs/21185/), Launcher Log and Overlay Log (https://support.ubi.com/en-GB/faqs/000033010)?

First: Created new user, did a clean boot. Nothing.

Second: Port forwarding almost destroyed my internet - I didn't change my router wi-fi passwords since May of 2014, so I had to manually reset both my router and wi-fi because default passwords would not allow me to log-in. Anyway, after an hour of tinkering, I have managed to forward ports both for uplay and odyssey and I still get log in error 0x00000004.

And ONCE AGAIN, I am able to connect to your in-game shop, which follows my purchases, just not the overlay, which leads me to believe that it's your issue not my PC's.

Please update your uplay client. I've been using it for almost five years and I've almost never had any issues. I want to continue being your customer.

larrykop1967
02-27-2020, 01:15 PM
Fascinating. I have waited almost ten days to get a generic link https://support.ubisoft.com/en-GB/Faqs/000025947/Basic-PC-Troubleshooting as a fix. As if I haven't tried that already...

And it's not only Odyssey overlay that's not working. It's EVERY uplay game that doesn't have the overlay working!

Yeah. i'm getting the same, ive sent screenshot's already, it's not my PC, it's something in the update, whether it's DRM, or win 7 not being supported properly anymore, i have 10 but prefer 7, i have more control over it, i also only use Uplay for Ubisoft games i don't use 2 client's so i don't link Steam or Epic, whether it's something to do with Epic, i just don't know, might be a Gaas issue with UPlay +, which i don't use

But it was working fine then there was an update and now it's not, so it's not my PC, as the support seem to suggest, i'll just play Origin's and OD without it now and then, but i might think twice about buying future games.

LovelyMallard
02-28-2020, 07:13 AM
Fixed. Ubisoft's Uplay client update.

Ubi-Woofer
02-28-2020, 09:22 AM
Hey all,

I had reported the issues with the overlay to the Uplay PC team, who investigated them alongside another reported issue with the client since the latest update :)

I am glad to hear that the issues are now fixed for you, LovelyMallard - can larrykop1967 and everyone previous let me know if these issues are resolved for you all now as well?

larrykop1967
02-28-2020, 10:16 AM
Hey all,

I had reported the issues with the overlay to the Uplay PC team, who investigated them alongside another reported issue with the client since the latest update :)

I am glad to hear that the issues are now fixed for you, LovelyMallard - can larrykop1967 and everyone previous let me know if these issues are resolved for you all now as well?

Happy to report, it's now fixed, thankyou Ubi-Woofer

Ubi-Woofer
02-28-2020, 12:37 PM
Happy to report, it's now fixed, thankyou Ubi-Woofer

Great! Thanks for letting me know, larrykop1967 :) I hope that this will be the case for everyone, but if not, don't hesitate to let me know.

apheXrush
02-28-2020, 01:09 PM
Fixed for me as well, thanks.

May I ask what was it? I guess some issue related to win7?

Ubi-Woofer
02-28-2020, 02:24 PM
Yay, great to hear it apheXrush.

I'm afraid I'm not privy to exactly where the issue lay, and I am unsure whether all issues are fully resolved as yet. If we receive further information that we are entitled to share, though, we will be sure to do so. :)

As before, if anyone is still experiencing issues with the overlay, please let me know so I can communicate this forward.

Stikuz
02-28-2020, 06:34 PM
Fixed 4 me too. Thank you.

UbiDork
02-29-2020, 01:17 AM
Stikuz: Fantastic! :) Glad to hear it, Stikuz!

LovelyMallard
02-29-2020, 10:49 AM
Oh, how rude of me. I forgot to say "thank you, Ubisoft."

So, thank you, Ubisoft.

Ubi-Woofer
02-29-2020, 12:27 PM
Glad to have helped, LovelyMallard :)

I do hope that this is the end of the issue, but as I have mentioned previously, I'm happy to investigate further should anyone report that it is still ongoing for them.