View Full Version : Initiates problem

12-03-2014, 07:17 AM
Initiates shows nothing I can't see my Level any one has that problem?

12-03-2014, 07:27 AM
Lots of reports of the same problem, myself included. You'll just get a response from ubi telling you to read the official thread about waiting for things to populate, but it doesn't seem to be the same issue as I get a 500 error every few tries with it.

12-03-2014, 10:29 AM
Same problem since yesterday. Was at level 12, busy getting achievements or whatever they are called. Now it shows nothing. Hope they fix it soon..

12-03-2014, 12:11 PM
I wish it was just broken for me. Been stuck at 12 for the past week or so and Initiates doesn't see my progress for AC 3 or Liberation HD. At 13 you get the final Initiates costume(which I believe is Ezio) and it's killing me being so close and I can't get the damn chest b/c it's still broken. I don't understand, they ran both an alpha and beta for Initiates, had missions, synced progress, and a couple in game items for 4 and it all worked fantastically. What the hell happened?

12-03-2014, 06:30 PM
I have never been able to log in to Initiates. It just hangs on loading please wait. But i have been able to open a couple of yellow chests.

12-03-2014, 07:41 PM
Same problem here.

12-03-2014, 07:43 PM
I can't even get Initiates to recognize I own any of the AC titles let alone sync to them. I've deleted cookies and started new games and it's still not even coming up that I own them!

12-03-2014, 09:17 PM
I can't even connect from game to initiates - connection error. When login from web I see only blank pages. Totally broken thing.

12-03-2014, 10:14 PM
please learn to use the sreach function or look under diffrent thread, sticky topics etc b4 making a nother thread about stuff that so many already are asking/talking about: