View Full Version : Bellac button mashing (bug?)

11-28-2014, 11:37 PM

I have been trying relentlessly to beat Bellac (button mashing) with both a keyboard and controller. I have numerous posts that it is a bug with others that say you just have to press faster. I tried this for over 2 hours and had two other people try but to no avail. Is this a new but after the third patch or is there something else wrong?

11-28-2014, 11:54 PM
It works, just hit the button really fast

11-29-2014, 12:26 AM
I had to change my grip on my controller to pound it fast enough....lol..worked at the end :)

11-29-2014, 12:31 AM
I use the turbo function on my pad. I hate these scenes because I'm not really fast at mashing buttons.

11-29-2014, 12:38 AM
I had the same problem last night, and I checked the support forum. Somebody there said: DON'T just press the button you're prompted to press (they were on console and were prompted with, I think B). They said move FORWARD and sometimes DIAGONALLY.

So instead of just pressing E, I pressed W (for forward) and sometimes A or D and BINGO. Got out of the loop. It's not actually a bug but just they didn't make it clear enough what we're supposed to do. It worked for me, and I hope it works for you too. Try it! Good luck!