View Full Version : ACU.EXE crash

11-28-2014, 12:35 PM
I just finished downloading the game today for the first time. After UPlay finished downloading my game I started playing it and everything was great.
When I got to sequence 2 memory 1 the game just stopped working. It say acu.exe stopped working.
I don't know what to do, I don't wanna start my game over again, and I've tried going offline.
What can I do to fix this? I'm on the latest patch (1.3) and my PC is capable of running the game.

11-28-2014, 01:47 PM
Same here...

I have the 344.75 Nvidia driver with a GTX765m, an i7 4700MQ, 8go of ram and a Crucial M500 120Go.

The game has worked only once since I installed Patch 3...

11-28-2014, 03:53 PM
With Patch 3 i am capable of running game in online mode again... after patch 2 was relised almost 2 weeks i was unable to play game in online mode ... now all works great !!:D

Send them ticket about your problem i think that still several players have issue with running the game ... mostly when u press CONTINUE in main menu .. gl fellows