View Full Version : Sequence 7 - Bellec Fight Problem

11-24-2014, 09:40 PM
Hi, i have a problem in that part of the game (Sequence 7 - Bellec Fight)... In the second part of the fight the game tells me to press "E" constantly and i press but nothing happend. I failed so many times... So i write that problem on Google and i saw that i'm not the only one who have that problem on PC. What can i do?

11-25-2014, 12:46 AM
my solution was to use smoke bombs and beat him to death.

11-26-2014, 03:24 AM
yeah, I did not like this memory at all. I never figured out what the 'B' (Xbox) was supposed to do. I pressed in constantly, it turned red, I died, I tried gain, and after a couple of times I suddenly beat him, still don't know how. Definitely weird.

11-26-2014, 10:06 AM
Try lowering your resolution. It works for me

11-27-2014, 12:20 AM
There are a couple other threads about this "glitch?". One solution was to switch controllers. I keep two controllers charged up so after trying several times to complete the fight without success I used my other controller and it worked. Keep pressing the button and it will automatically propel you into the next part of the fight if everything is working correctly.

11-27-2014, 05:28 PM
I tried so many tips to complete this memory but for nothing... I hope the new patch will fix this problem so i think i will wait for patch 3 to come out.