PDA

View Full Version : [Ubisoft_Account] Can not download Uplay launcher from uplay.com



HSS_Joker
11-23-2014, 12:43 AM
Hi there,

I hope someone can help me with this and hopefully not the only one with this issue.

So i have tried to download the ubisoft launcher from the offcial website uplay.com however each time i click on the link it says
"This webpage is not available" under that is says "Reload" but no matter how many times i have tried it comes to the same page.
Am i missing something here?, i have done the firewall check and making sure i have everything up to date and also have given
an exclusive rule in my anitvirus to allow chrome do its thing.

If anyone has any idea please comment below, i would appreciate a quick response.

Cheers

Ubi-Leorthian
11-24-2014, 04:47 PM
Hello HSS_Joker,

Thank you for contacting us. I went there on Chrome myself just a moment ago and was able to start the download without issue (here is the link (https://static3.cdn.ubi.com/orbit/launcher_installer/UplayInstaller.exe)). Have you tried clearing your Chrome browser cache? If Chrome has a cached version of the website, it may be causing the issue you're experiencing.

If that doesn't resolve your issue, please contact the Ubisoft Support team for further assistance. You can contact support through our ticket system's webform found by clicking on "My questions" on this page: https://support.ubi.com and then clicking "Ask a Question".

If you have any issues using the webform, or if you cannot access your account, you can contact support for assistance through their Facebook page: https://www.facebook.com/UbisoftSupport, Twitter account: https://twitter.com/UbisoftSupport or by phone: https://support.ubi.com/en-us/FAQ.aspx?platformid=60&brandid=2030&productid=3888&faqid=kA030000000eiChCAI