View Full Version : Game Unplayable!! Far Cry 3 has Stopped Working

11-22-2014, 05:35 PM
EDIT: I fixed it by uninstalling (delete local contnet) checking the folder to make sure everything was gone and then reinstalling but on the old hard drive I had tried to move it from. My friend and I suspect it was the drm on the game blocking me from loading it onto another hard drive and playing it off of there. Hope this helps someone else.

"Far Cry 3 has stopped working" is the message I get whenever I try to play the game the last two days. Uplay opens but when the game tries to open I get this message and it closes. Are others having the same crashing problem right now??!!!!

Things I have ALREADY tried:
-verify game cache multiple times
-delete local content and reinstall three times
-did all the second party installers thing on the support page and rebooted
-redownloaded uplay twice

ALL MY OTHER GAMES WORK with no problems. None of the other games however use UPlay. I don't think it is on my end as I am running a pretty good rig with a MSI twin frozr Ge Force Gtx 750ti graphic card and a 600w power supply fthat runs all my other games completely fine. I have noticed a lot of other people having problems with the game.

Note: the game worked ok before a few days ago. I did just move all my games from one external hard drive to the other. All my other games play fine though. I am running Windows 7 64 bit.

Here is my Windows Error Log:

Log Name: Application
Source: Application Error
Date: 11/22/2014 10:16:52 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Faulting application name: farcry3_d3d11.exe, version:, time stamp: 0x51226a2f
Faulting module name: FC3_d3d11.dll, version:, time stamp: 0x512269ef
Exception code: 0xc0000005
Fault offset: 0x000ae0ba
Faulting process id: 0x1d88
Faulting application start time: 0x01d0066fb6dada88
Faulting application path: J:\SteamLibrary\steamapps\common\Far Cry 3\bin\farcry3_d3d11.exe
Faulting module path: J:\SteamLibrary\steamapps\common\Far Cry 3\bin\FC3_d3d11.dll
Report Id: f779b2f8-7262-11e4-b521-002618713862
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<TimeCreated SystemTime="2014-11-22T16:16:52.000000000Z" />
<Security />
<Data>J:\SteamLibrary\steamapps\common\Far Cry 3\bin\farcry3_d3d11.exe</Data>
<Data>J:\SteamLibrary\steamapps\common\Far Cry 3\bin\FC3_d3d11.dll</Data>