PDA

View Full Version : [IMPORTANT] Uplay Dose Not Update Properly



TheJagji
11-19-2014, 05:39 AM
Ok, this happened to me today for the first time. I went to load Uplay, and it comes up with the looking for update thing, and away it goes. It starts downloading it, but very quickly drops to 0 download speed. After a bit, it then skips the update and lunches Uplay anyway. I am not sure what is going on with it.

It also did it when I went and updated FarCry 4. However, if I left it, it would keep connecting and disconnecting, so it did eventually download, but because it kept cutting out, it took way to long.

The rest of my net programs work (STEAM, Firefox and so on) so I am ruling out a modem problem. I also re-booted my PC, and it did not help ether.

Has anyone else had this problem? Anyone got a fix?

Ubi-Leorthian
11-19-2014, 03:57 PM
Hello Jagji,

Thank you for contacting us with your issue. It sounds like there is something interfering with your connection to the server, so downloads aren't progressing. Sometimes software on your PC, or blocked ports on your router can impede your connection. Try following the advice in this support post and see if it helps: https://support.ubi.com/en-US/FAQ.aspx?platformid=9&brandid=22&productid=2716&faqid=kA030000000eSGkCAM

If your issue persists, please try contacting the Ubisoft Support team for assistance with your issue. You can contact support through our ticket system's webform found by clicking on "My questions" on this page: https://support.ubi.com and then clicking "Ask a Question".
If you have any issues using the webform, or if you cannot access your account, you can contact support for assistance through their Facebook page: https://www.facebook.com/UbisoftSupport, Twitter account: https://twitter.com/UbisoftSupport or by phone: https://support.ubi.com/en-us/FAQ.aspx?platformid=60&brandid=2030&productid=3888&faqid=kA030000000eiChCAI