PDA

View Full Version : [EASY FIX] Stutter/Frame Skipping Far Cry 4!



DrumPixels
11-19-2014, 04:33 AM
Hello,

First of all I want to say my english is terrible. BUT... I've found a easy way to fix most of the stutters/frame skipping.
This fixed 100% of the stutter problems. Playing with a Gigabyte AMD HD7870.

- Open My documents > Open Folder My Games
- Open Folder Far Cry 4
- Open the GamerProfile.xml file with Notepad

- Change this setting; (Press CTRL+F to open the search function)

DisableLoadingMip0 = "0"

to

DisableLoadingMip0 = "1"

- This may not work for all videocards/setups. If not try this: (Thanks Patilion)

GPUMaxBufferedFrames="0"

to

GPUMaxBufferedFrames="1"

Save the file and close. Open it again to double check of the settings has been saved.

Launch the game and HAVE FUN!
Let me and the others know with a reply of this fix worked for you! I'm sure it does tho..

(If you are unable to save the game make sure you run the game as Administrator)

(Close google chrome while playing games. This gives you 5~15 FPS boost)

borracas
11-19-2014, 05:25 AM
OMG!!!! Thank you! Zero stuttering now! Pitch black shadows still persist however with SLI config. Are you experiencing this by chance? :o

DrumPixels
11-19-2014, 05:43 AM
No I don't have trouble with pitch black shadows. But I've read to fix this you have to lower the Ambient Occlusion in the video options menu to SSAO.

BinaryAudio
11-19-2014, 05:59 AM
Many thanks for your suggestion. It has dramatically improved performance here. I was getting some lousy stuttering, especially driving. This seems to have fixed that.

Nyadc
11-19-2014, 06:00 AM
Use this "fix" at your own discretion, this disables mipmaps.


You have different resolution sizes for a single texture. Up close you have the highest and far away the lowest.

With mipmaps ON, the game automatically generates a number of textures between those stages, so that the transition is smooth. With mipmaps OFF the textures will "pop-in" as you move closer, since there's no interpolation.

Obviously this saves a lot of texture memory, and probably there's something buggy in the game code that makes the creation of mipmaps lag everything.

Grizzly_Dulani
11-19-2014, 06:58 AM
This actually helped. Stuttering is not as bad as before but it's still there, I notice it from time to time. SLI config is still terrible though, both my GPUs are rapidly fluctuating in usage. I'm sure it will be fixed with a patch, in the mean time I'll be playing DA: Inquisition (which is smooth btw).

verdammt23
11-19-2014, 11:38 AM
thx buddy :) it really helped , no more stuttering !

Tuc0Ramirez
11-19-2014, 11:52 AM
Nice, definetly helped but still noticeable in vehicles (well more than noticeable lol). Still unplayable combined with the aweful mouse movement. A few hairs away from being great.

Patilion
11-19-2014, 02:21 PM
And set GPUMaxBufferedFrames="0" to GPUMaxBufferedFrames="1"
By my settings it was 0 en now 1 and its runs verry smooth

Mwelling12
11-19-2014, 03:18 PM
This does NOT resolve the stuttering that occurs while traveling rapidly around the environment as a result of having High/Very High/Ultra Textures setting enabled.

Dmny23
11-19-2014, 05:32 PM
Thanks @Patilion and @DrumPixels. This removed most of my stuttering while driving and drastically improved my experience (it's not placebo).

DragonRR
11-19-2014, 09:23 PM
And set GPUMaxBufferedFrames="0" to GPUMaxBufferedFrames="1" By my settings it was 0 en now 1 and its runs verry smoothI'm running an Nvidia Titan (v1) with an i7 980X CPU. I had massive stuttering from the very beginning of game when sat at the table with the monkey heads. In the torture area there was a lot of stuttering when simply moving the mouse left to right. Whilst some moments seemed quite smooth the game was pretty unplayable especially when by the river in the first playable area. I tried most of the in game settings, Ultra/High/Low, different resolutions, Vsync on/off etc..The DisableLoadingMip0 = "1" setting had no effect on my system however setting this GPUMaxBufferedFrames="1" fixed the whole problem and made everything run smoothly. I could even turn the settings back up. Thanks Patilion! :)

AndyBoardy
11-19-2014, 10:00 PM
This does NOT resolve the stuttering that occurs while traveling rapidly around the environment as a result of having High/Very High/Ultra Textures setting enabled.

Worked for me masive improvement, playing with all setting on Ultra.

Thanks Drum

SPARTACUS_QC
11-19-2014, 10:36 PM
Thanks @Patilion and @DrumPixels. This removed most of my stuttering while driving and drastically improved my experience (it's not placebo).

Thank you son much :D confirm playing on NVIDIA settings Asus Strix GTX 970 a lot better now ! Now i can play while waiting for a officiall fix :cool:

Homerloif
11-20-2014, 12:45 AM
Thanks for the suggestion, for me it made no difference to the stuttering, but the graphics quality was worse. As with some others, I have an ASUS Strix GTX 970.

I can only hope Ubi release a fix for this soon as the game is almost unplayable for me.

wootwoots
11-20-2014, 12:52 AM
it look to improve a bit... but its still stuttering saddly :(

need a real ubi patch to fix that... ><

drider86
11-20-2014, 01:35 AM
THIS:

Set GPUMaxBufferedFrames="0" to GPUMaxBufferedFrames="1"

Has fixed the game for me. 0 lag and stutering on AMD graphic cards.

Big Thanks to DragonRR

Ironwoods56
11-20-2014, 01:54 AM
Pretty sad how modders are solving these problems faster than Ubisoft.

AJRimmsey
11-20-2014, 02:10 AM
Pretty sad how modders are solving these problems faster than Ubisoft.

are you saying that developers should initiate these fixes as soon as they are reported,and lets say...errr reward those who find and release the info ?

i mean its not as though this has been going on for years where modders and amateurs have found more fixes faster than devs who have to work on many projects at once.



god bless the enthusiast,as it caused me to buy this game for 30 instead of waiting for "official" help and buying it for 10 many months from now.

there is a massive amount of talent out there untapped because of dev ignorance and arrogance.


tap it you NUMPTYS ;)

Mwelling12
11-20-2014, 02:29 AM
The placebo effect is really a fascinating phenomena.

This "fix" does not work to relieve the stuttering caused by the texture streaming. Neither the mipmap change nor the maxgpubuffer change. Try running a program that displays the framerate on screen. Then tell me it doesn't drop while traveling rapidly around the environment.

It doesn't work. The game needs patching.

DrumPixels
11-20-2014, 02:37 AM
Glad to see "this temporary fix" is working for most of you! Lets hope there will be a patch soon ;)

raverill
11-20-2014, 02:10 PM
The placebo effect is really a fascinating phenomena.

This "fix" does not work to relieve the stuttering caused by the texture streaming. Neither the mipmap change nor the maxgpubuffer change. Try running a program that displays the framerate on screen. Then tell me it doesn't drop while traveling rapidly around the environment.

It doesn't work. The game needs patching.

You're spot on...couldn't agree more.. Have tried all the 'fixes' and they make no difference..Game needs some work done to cure this problem..Just hope they do cos it spoils what potentially is a good game.

Living in hope...:rolleyes:

capt_crab
11-20-2014, 03:02 PM
Great fix. Thanks drumpixel. Worked for me, although I was only getting stutter when in vehicles and I wouldn't call it game breaking. It was annoying though.

Fman83
11-20-2014, 04:16 PM
Drum thank you for this post, far cry4 is stuttering free for my pc, thanks alot!!

Its now even more fun to play this game on high settings




Hello,

First of all I want to say my english is terrible. BUT... I've found a easy way to fix most of the stutters/frame skipping.
This fixed 100% of the stutter problems. Playing with a Gigabyte AMD HD7870.

- Open My documents > Open Folder My Games
- Open Folder Far Cry 4
- Open the EditorGamerProfile.xml file with Notepad

- Change this setting; (Press CTRL+F to open the search function)

DisableLoadingMip0 = "0"

to

DisableLoadingMip0 = "1"

- This may not work for all videocards/setups. If not try this: (Thanks Patilion)

GPUMaxBufferedFrames="0"

to

GPUMaxBufferedFrames="1"

Save the file and close. Open it again to double check of the settings has been saved.

Launch the game and HAVE FUN!
Let me and the others know with a reply of this fix worked for you! I'm sure it does tho..

(If you are unable to save the game make sure you run the game as Administrator)

(Close google chrome while playing games. This gives you 5~15 FPS boost)

toastytoast
11-20-2014, 08:00 PM
This doesn't do anything to improve frame rates whatsoever. Frame skipping has nothing to do with this at all. Maybe stuttering is improved as data an the HDD is accessed differently with these settings. But anyone claiming "100%" stutter free gaming is very misleading. Show some screenshots/videos with the frame rates listed in the image. I doubt you are getting anything close to what is optimal


http://www.geforce.com/whats-new/guides/far-cry-4-graphics-performance-and-tweaking-guide

This could help though. I'd try disabling ATOC and could try UseD3D11="0"

Flynt819
11-20-2014, 08:06 PM
This isn't a placebo, it is a legitimate fix/improvement. No more stuttering when driving around the map. Thanks for the tip.

SookMePlooms
11-20-2014, 08:30 PM
The placebo effect is really a fascinating phenomena.

This "fix" does not work to relieve the stuttering caused by the texture streaming. Neither the mipmap change nor the maxgpubuffer change. Try running a program that displays the framerate on screen. Then tell me it doesn't drop while traveling rapidly around the environment.

It doesn't work. The game needs patching.

Couldn't agree more mwelling12

It does work for the general stuttering. However this is not a fix. It has a major impact on texture quality, especially if you're capable of running the game with ultra textures. At lower texture settings you might not notice as much of a difference but it's there and some textures look terrible.

It also doesn't "fix" the random "stalls" when you're moving through the environment at high speeds (at any quality settings). I refuse to call this stuttering as the game engine will just freak out and pause for about a second when it happens. It completely breaks the immersion of the game. I've ended up veering off a cliff or into a tree when the game does this, recovers and your controller/keyboard input suddenly kick in and sends the car/bike off in a random direction.

RoadblockCement
11-20-2014, 09:54 PM
Im running the game from a SSD on Win 7 64bit , i7 cpu and gtx780 and it plays very smooth for me on high settings , Im using the last of the rock stable drivers the old nvidia 314-25 graphics driver and will not change it as it runs all my games perfectly with no issues , I dont know how why for some the game is smooth and others its choppy when they have higher spec machines , I feel it must be the software and drivers environment on all the different computers that upset things and the problems are not really the game , more so the game and its compatibility with your particular PC .

toastytoast
11-20-2014, 10:15 PM
Im running the game from a SSD on Win 7 64bit , i7 cpu and gtx780 and it plays very smooth for me on high settings , Im using the last of the rock stable drivers the old nvidia 314-25 graphics driver and will not change it as it runs all my games perfectly with no issues , I dont know how why for some the game is smooth and others its choppy when they have higher spec machines , I feel it must be the software and drivers environment on all the different computers that upset things and the problems are not really the game , more so the game and its compatibility with your particular PC .

Curious why you are using a legacy driver for your 7 series card. To my knowledge that driver is really only benefiting 4/5 series cards. You'd likely benefit from using new drivers which actually have optimizations for later tier cards.

RoadblockCement
11-20-2014, 10:51 PM
Curious why you are using a legacy driver for your 7 series card. To my knowledge that driver is really only benefiting 4/5 series cards. You'd likely benefit from using new drivers which actually have optimizations for later tier cards.

Sorry it was a hacked 314.22 not .25 , I had nothing but trouble with updated graphic drivers eventually toasting my card which was a 680 , bought a 780 and installed this driver and it is rock stable in every game I have thrown at it giving great graphics and high fps , stability is the number one thing for me and Im of the opinion if it aint broke dont fix it , I dont want to chase rainbows looking for minor fps etc , I just love how stable this card driver combo has been for me .

There is lots of info on google about this driver running 7 series cards .

SPARTACUS_QC
11-20-2014, 11:00 PM
Couldn't agree more mwelling12

It does work for the general stuttering. However this is not a fix. It has a major impact on texture quality, especially if you're capable of running the game with ultra textures. At lower texture settings you might not notice as much of a difference but it's there and some textures look terrible.

It also doesn't "fix" the random "stalls" when you're moving through the environment at high speeds (at any quality settings). I refuse to call this stuttering as the game engine will just freak out and pause for about a second when it happens. It completely breaks the immersion of the game. I've ended up veering off a cliff or into a tree when the game does this, recovers and your controller/keyboard input suddenly kick in and sends the car/bike off in a random direction.

After playing a while i see that it is a placebo effect and it does impact a lot the texture quality ..so yes ubisoft we need a patch ASAP :rolleyes:

dangel666
11-21-2014, 12:56 AM
First thing I'd do is check your VRAM usage - if you're exceeding the card's ram then streaming textures will cause stuttering. Games are pushing much higher VRAM usage of late (one of the reasons I moved from 2gb cards to 4). May not help but it pays to check this first before assuming it something else.

The_Tomcraft
11-21-2014, 01:48 AM
Hey

Thanks to the help from DrumPixels - i can finally enjoy the game!
NOT A SINGLE STUTTER/LAG anymore!



BUT:
After i did the changes in the
"GamerProfile.xml"
(same directory)



i7 4770 - GTX 680 - 16GB RAM - Win8
= Ultra Settings flawless playable without problems.

rrhazzy
11-21-2014, 05:25 AM
Hey

Thanks to the help from DrumPixels - i can finally enjoy the game!
NOT A SINGLE STUTTER/LAG anymore!



BUT:
After i did the changes in the
"GamerProfile.xml"
(same directory)



i7 4770 - GTX 680 - 16GB RAM - Win8
= Ultra Settings flawless playable without problems.
Enjoy playing low resolution textures then.

Falkenbach11
11-21-2014, 09:16 AM
Hi there thanks for the advice had stuttering problem, did what you said and it's solved my stuttering problem by 99%
Game runs smooth now very happy

Excellent advice thank you again...

ironhead111
11-21-2014, 04:09 PM
Thanks, this made my game actually playable. The game is pretty fun when you can drive without stutter and end up unintentionally driving off a cliff. This does leave you with crappy resolution textures though. This game needs to be patched. Fast.

The_Munc_e
11-21-2014, 10:50 PM
How big of a visual impact does this fix have? I notice a lot more texture pop in, and it just doesn't really seem as smooth? Is Ubisoft working on an official fix? The stuttering is too much. I have an i7 4790k and msi twin frozr gtx 980

F3TiSH
11-21-2014, 11:00 PM
Just imagine how stutter free this game would be if someone found a way to turn off all textures, everything white, 10000fps 0 stutter.

With mipmap edit changing textures between low and ultra makes basically no difference in how everything looks, only thing that appears on ultra are sun reflections on weapons, rivers etc.So you might as well use low textures without this edit. Wish they focused on this issue instead of adding more fur.

DragonRR
11-22-2014, 12:29 AM
THIS:

Set GPUMaxBufferedFrames="0" to GPUMaxBufferedFrames="1"

Has fixed the game for me. 0 lag and stutering on AMD graphic cards.

Big Thanks to DragonRR

No problem but it was actually Patilion who discovered this. Obviously it may not work for everyone but there is no placebo in my case, the game was unplayable with this set to 0 and smooth (no stuttering at least) on ULTRA settings when set to 1. It may have some detrimental impact on something but I havent' actually seen anything wrong. I don't use the mipmap setting as it made no difference on my system.

fat_zac_attack
11-22-2014, 06:51 AM
nope, doesn't change anything for me either on both of my rigs. 780 ti and 290 setup. :(

Still a stutter fest

Thanks Obamasoft lol

Frox_Precision
12-01-2014, 07:32 PM
There is no Far Cry 4 folder for my in the "My Documents" folder. I installed via Ubisoft, not Steam. Can't find the EditorGamerProfile anywhere.

Damian....
12-01-2014, 07:51 PM
No problem but it was actually Patilion who discovered this. Obviously it may not work for everyone but there is no placebo in my case, the game was unplayable with this set to 0 and smooth (no stuttering at least) on ULTRA settings when set to 1. It may have some detrimental impact on something but I havent' actually seen anything wrong. I don't use the mipmap setting as it made no difference on my system.

The detrimental effect is it only gets rid of the movement stutter, it does nothing for the biggest problem, loading stutter while moving around the map. The only thing that alleviates that is to make the textures look like crap with the LoadingMip change. Ubisoft really screwed this game on PC by not optimizing.

tunnelcat
12-01-2014, 10:12 PM
There is no Far Cry 4 folder for my in the "My Documents" folder. I installed via Ubisoft, not Steam. Can't find the EditorGamerProfile anywhere.

Did you look under the My Games entry in My Documents? It's hiding in there.

The-Gurhm
12-02-2014, 01:04 AM
This band-aid solution did not work for me or my friends. We need a solid fix from Ubi on this one ASAP!

DrumPixels
12-06-2014, 03:00 AM
Play the game almost completely stutter free with lower texture quality..

or

Keep complaining on the Ubisoft forums because you are not able to play the game properly.

Hmm.. ;)

We all do want patches to finally enjoy the game. But hating on the forums doesn't help them to release patches faster. I completely finished the game with lower texture quality because of the ''fix''. Did it bother me? Yes it did.. but maybe it will take ubisoft months to fix the stutter issues and by then I will be playing GTA V on the pc.

CiscoStud
12-08-2014, 12:37 AM
Play the game almost completely stutter free with lower texture quality..

or

Keep complaining on the Ubisoft forums because you are not able to play the game properly.

Hmm.. ;)

We all do want patches to finally enjoy the game. But hating on the forums doesn't help them to release patches faster. I completely finished the game with lower texture quality because of the ''fix''. Did it bother me? Yes it did.. but maybe it will take ubisoft months to fix the stutter issues and by then I will be playing GTA V on the pc.

After paying $69 for a brand new game, 'we' should be able to come home and enjoy our game. But instead we are here reading through forums on how to fix the broken game we paid for and occasionally have to put up with post from apologist bootlickers like yourself.

Sr_0v3rkill
12-08-2014, 07:32 PM
I have no problem at all with the game in ultra. But, my wife's system has and since far cry 3. It's actually the same symptoms. That annoying stuttering and the fps is high. Funny thing is that we both have the same twin frozer 290x from msi. Only difference is that she has a 6 core and I have an 8 core cpu, both AMD. Her's is clocked to 4.1 GHz. She scores 9230 on 3dmark, which is on the extreme area. I just don't get it. This game has a lot of problems. I am losing faith on Ubisoft a lot this days.

tsdeaton
01-12-2015, 04:48 AM
my gamerprofile.xml has a lot of settings set to low and very high but while in game all my settings show as ultra.... anyone know whats up with that? are the graphics being held back? lol

tsdeaton
01-12-2015, 04:52 AM
I have no problem at all with the game in ultra. But, my wife's system has and since far cry 3. It's actually the same symptoms. That annoying stuttering and the fps is high. Funny thing is that we both have the same twin frozer 290x from msi. Only difference is that she has a 6 core and I have an 8 core cpu, both AMD. Her's is clocked to 4.1 GHz. She scores 9230 on 3dmark, which is on the extreme area. I just don't get it. This game has a lot of problems. I am losing faith on Ubisoft a lot this days.

for amd the game requires an 8 core processor. it doesnt matter what her 6 core is clocked. the game uses 8 cores for amd. i had the same issue going in on far cry 4. had the 6 core amd fx running at 4.1 and went out and got the 8750 8-core running stock and it was a HUGE improvement. without these fixes for the stuttering i was running the game great! with only a few stutters during the driving scenes

The-Gurhm
01-12-2015, 06:57 PM
For those that still get significant stuttering/hitching (which includes myself and my friends), my Ubisoft service rep just sent me a message this morning stating that the Development Team is continuing to look into why the issue is occurring to provide a fix.

...so, just keep posting or updating your service request and play something else until they figure out the problem. Right now I'm playing Alien Isolation which is freakin fantastic, beautiful and runs perfectly.

NikolasDidonis
03-12-2015, 11:20 PM
For those that still get significant stuttering/hitching (which includes myself and my friends), my Ubisoft service rep just sent me a message this morning stating that the Development Team is continuing to look into why the issue is occurring to provide a fix.

...so, just keep posting or updating your service request and play something else until they figure out the problem. Right now I'm playing Alien Isolation which is freakin fantastic, beautiful and runs perfectly.


FARCRY4 do not Stutter/Frame Skipping if you disable sli then all is normal just FPS drops to 30 ****UP

gabojoker
04-18-2015, 01:13 AM
Hey, thanks alot for that! Really do appreciate it! ;)

Butcherbird59
04-18-2015, 01:41 AM
Actually you can try increasing GPUMaxBufferedFrames="1" and see if it makes a difference but 1-frame is the sweet spot for 1GB cards

Necronomicon999
08-04-2015, 09:46 PM
A bit later but thanks mate.



Cheers,
-Albi

S3kk3N
08-17-2015, 06:05 PM
DrumPixels THANK YOU It freaking works!! :D

trizul96
01-11-2016, 10:34 AM
thank you, its work :)

Nickwride
02-13-2017, 07:56 AM
I just bought a Gigabyte Extreme Gaming GTX1080 WaterForce card the other day and thought I'd try far cry 4.

The Micro-Stutter is just awful on this game.

Even with the .XML tweaks the stutter is the worst I've seen since source engine games on my old GTX970. I also followed another post saying to set power to "Maximum performance" and pre rendered frames to "3" but alas I get microstutter every half to one second of play on what would otherwise be butter smooth 120fps. As Nvidia can't get their drivers right. As older drivers are worse, I can only hope Ubi releases an update to factor in the GTX1080 cards.

Other main Specs
Windows 7 pro x64
Intel Core i74790-k @4.0Ghz
32gb Cprsair Vengeance Pro 2400 DDR3 RAM (Down Clocked to 1866Mhz for System Stability)
Sound Blaster Zx
Logitech Z906 THX 5.1 Speakers