PDA

View Full Version : Didn't expect much... Disappointed anyway.



Necessary__Evil
11-18-2014, 06:43 PM
Specs before I start my rant.

I5 2500k @ 3.3GHz
GTX 760 2gb stock
8GB RAM
Win 7 x64

First off the game set me on everything High so I toned down some settings which I know are a hogger when wanting to keep a stable FPS with such poor PC copies of the game. I then start the game looking forward to what's ahead but didn't expect much performance wise, 50FPS? Fine. I then get to start playing when I have to look around that room and it feels funny, jittery? I couldn't quiet put my finger on it but it didn't feel right so I quickly checked the FPS counter and it was at 60 and didn't dip anywhere despite being able to see the FPS drop when looking at the flashing chest because it was clearly dipping in frames that it became slow. I then got outside and after the prologue and you reach the town I proceeded to run around exploring, and I look at some vegetation and run sideways the game becomes a slide show... The game itself seems to run but the enviornment has massive stuttering and I won't even bother going in to details with how it is driving...

I've just tested the game with the new drivers and it's still the same thing. Impossible to play because running through long grass etc is just a mess...

BamGfAsRpd
11-18-2014, 07:49 PM
Did you buy your own copy? Pirated versions have issues with graphics.

Necessary__Evil
11-18-2014, 08:01 PM
Did you buy your own copy? Pirated versions have issues with graphics.

Yep, it cost me just under 30. Limited Edition.

https://plus.google.com/107620107048304374560/posts/FAJNqpTXNVk?pid=6083119681097570994&oid=107620107048304374560&authkey=CPOs1L-FrfKhOQ

I'm not sure if you can view this but here is a video showing the strange stutter/jittering when moving about but if I look up at the building it runs butter smooth.