PDA

View Full Version : Another possible FPS-Stuttering workaround



MorusLP
11-16-2014, 05:08 PM
Hey guys!

Today I've had a look at some of the data files which are dealing with the graphics of Unity. If you played Watch_Dogs on PC, you might know that there were some things which you could still tweak if you had a look at these data files - however, in Unity it is kinda the same.
In my case, I found these two files called "ACU" and "GFXSettings.ACU" in C:\Users\[your name]\Documents\Assassin's Creed Unity (I'm using windows 7, not certain about this being the same on other windows versions).
In these two files you can find 2 settings, which are not visible in the actual game menu, these being reflections and character quality (screenshot).
https://pbs.twimg.com/media/B2kxSNRCYAEDDhG.png:large
I tested a bit around with these settings, and surprisingly turning reflections into false in the GFXSettings.ACU file provided me a much better performance with nearly no stuttering in the free-roaming.
In missions however. you may still encounter some stuttering here and there, but in my case, it still stutters less.
In terms of how the game looks after turning the reflections to false in this file, I haven't noticed any difference, though my game runs better now.
I also have to mention, that I use the "nvidia inspector" to lock my framerate at 30 FPS, because my GPU is kind of a bottleneck - but if you have a better system it might be possible that you don't even have to do that.

Keep in mind, that this is only a workaround until Ubisoft fixes the FPS problem, hence I can't guarantee this workaround to work for you.

My specs:

CPU : Core i5-3570K 3.4GHz
GPU : GeForce GTX 660 Gigabyte OC Edition
RAM: 8GB
Windows 7

My Unity settings;

Environment: High
Textures: High
Shadows: Low
Ambient Occlusion: SSAO
AA: FXAA
No Blooming

EDIT: I'm glad, that it works for some people ;) If you can't see any difference, be sure to have the GFXSettings.ACU locked as "read only" as MauriceWijma proposed.

silverfall1986
11-16-2014, 05:22 PM
You should actively monitor what your gpu usage is like in the game. You could just be lowering settings so that the drops in gpu performance doesn't effect you as much, but the drops in performance still might actually be happening; I.E you're not actually fixing the problem. (if you're getting gpu utilization drops, which you should be on a gtx 660).

The only real fix for this is if ubisoft is able to fix it and if their engine is causing this problem then there's a good chance it can't be fixed.

jctk55
11-16-2014, 10:46 PM
Thank you so much! This actually works! I can finally play the game in peace, Without raging over then damn FPS XD

A-p-o-l-l-y-o-n
11-16-2014, 11:02 PM
OMG THIS WORKS. I mean, it doesn't completely get rid of it, but it gets rid of the terrible building lag. So, this means that it's the massive reflections on the buildings (glass, gold, etc) that is causing the excessive draw calls, which in turn is causing FPS issues. Thanks for this.

TheSaftschubse
11-16-2014, 11:09 PM
Works for me as well! Thanks so much for that!
But keep in mind that everytime you change the graphics settings ingame, the settings for reflections will be reset!

You should inform Ubisoft about that.

AlonsoVarEmreis
11-16-2014, 11:20 PM
Wow, it's still not perfect but playable now. Thank you, you're amazing.

nabilbousbai
11-16-2014, 11:55 PM
It doesnt change for me.
Actually, I noticed that when I launch the game, the values that I previously set are back to default

edit : When I change Reflections to "False", the game set it to "True" when in-game

firitza
11-17-2014, 02:42 PM
I confirm what he said @nabilbousbai.

MauriceWijma
11-17-2014, 04:08 PM
If it changes back, you could try to go into the properties of the file, and check if it can be set to "read only".

If so, just make the change in the file again, save it, and make it "read only". This might make some problems, but it won't let the game change the settings.
I haven't tried it for myself, because it is not changing in my file, but this is a standard way of preventing your system from changing file content.

DjKamo
11-17-2014, 04:21 PM
I'll try it and I'll report here :D

Mel_Sidhe
11-17-2014, 05:13 PM
hrmm ...

Upon Reflection ... I supposed this makes perfect sense.

wootwoots
11-17-2014, 06:13 PM
That's a very nice find :0
The visual dont change a lot, and it allowed me to have 5-10 more fps :0

nabilbousbai
11-17-2014, 07:27 PM
If it changes back, you could try to go into the properties of the file, and check if it can be set to "read only".

If so, just make the change in the file again, save it, and make it "read only". This might make some problems, but it won't let the game change the settings.
I haven't tried it for myself, because it is not changing in my file, but this is a standard way of preventing your system from changing file content.

You Sir deserve a medal ;)
It worked, I gained 10-15 fps !

topeira1980
11-17-2014, 07:43 PM
hmm.... this "tweak" is giving me an extra 3 fps or so, i think.
i am not sure what the difference is in visuals though. i would think it's reflections on surfaces but now i kinda feel like it's some filter all over the image. i cant put my finger on it.

topeira1980
11-17-2014, 07:48 PM
You Sir deserve a medal ;)
It worked, I gained 10-15 fps !

what specs do you have?
what settings are you running the game on?
how much fps did u get before the tweak and how much after?

Edeniuss
11-17-2014, 08:10 PM
OMG! This actually works for me! AWESOME! My fps dropped after the patch 2 update. Now I can enjoy Unity again! Will share your thread with other fellow assassins. :)

Meridius56
11-17-2014, 08:34 PM
tried it, set the file to read-only, nothing changed.

the placebo is strong with this thread.

nabilbousbai
11-17-2014, 08:49 PM
what specs do you have?
what settings are you running the game on?
how much fps did u get before the tweak and how much after?

I5 2500K @ 4.4 Ghz
HD 7950
2 * 4 g
1080p @ low, fxaa, ssao
I had 25-30 fps before, now 30-40

TheSpoonelite
11-17-2014, 09:39 PM
Unfortunately this didn't work for me. I have a pretty much identical systen except im using a AMD FX-6300. My computer was running the game fine, got up to sequence 7 and then I think it melted my computer. I now have pretty consistant stuttering. LoL even stated stuttering. I'm upgrading to a 770 tomorrow so I'll let you know if that actually solves anything. Becareful letting GeForce Optimize this game, that's what i did before it melted me.

wootwoots
11-17-2014, 10:07 PM
tried it, set the file to read-only, nothing changed.

the placebo is strong with this thread.

Not sure, the first time i tried, i really had a nice fps boost. Also feeled that when moving the camera around that was "smoother"
But now... i switched serverals time between default and reflections stuff off, to see the graphic difference. At the exact same place, and yeah, no more fps differences.

Maybe its also due to "luck" mean.. sometime after game start i have tons of stutter ( and fps under 30 ) and sometime ( after serverals try game restart -_-" ) game run "correctly" with fps always above 30 ( what a sad thing for a pc game... >< )
Sooo... maybe that was just a "lucky game start all work fine"

but still this game is a utter sh*t for the optimisation / stability.

Meridius56
11-17-2014, 10:17 PM
Not sure, the first time i tried, i really had a nice fps boost. Also feeled that when moving the camera around that was "smoother"
But now... i switched serverals time between default and reflections stuff off, to see the graphic difference. At the exact same place, and yeah, no more fps differences.

Maybe its also due to "luck" mean.. sometime after game start i have tons of stutter ( and fps under 30 ) and sometime ( after serverals try game restart -_-" ) game run "correctly" with fps always above 30 ( what a sad thing for a pc game... >< )
Sooo... maybe that was just a "lucky game start all work fine"

but still this game is a utter sh*t for the optimisation / stability.

Performance differs between districts heavily, for example, on the small island with the café I get 20-25, while in the northern parts of the city I get 30-35FPS. Maybe that's why you felt an "improvement".

topeira1980
11-17-2014, 10:56 PM
Performance differs between districts heavily, for example, on the small island with the café I get 20-25, while in the northern parts of the city I get 30-35FPS. Maybe that's why you felt an "improvement".

for me the southern islands have the best performance. but the northern ones are definitely better than the middle island. the area around notre dame gives the 24fps and cafe theatre around 18.

TheSaftschubse
11-17-2014, 10:56 PM
This works.

The Problem is that the engine always enables the reflections again, even when the config is set to read only.
It's not a placebo, but you have to actually change and save the properties before every start. Even when you edited the config and set it to read only, the engine itself wil enable reflections again, no matter the config is set. Ubisoft has to take a look at it.

topeira1980
11-18-2014, 08:39 AM
This works.

The Problem is that the engine always enables the reflections again, even when the config is set to read only.
It's not a placebo, but you have to actually change and save the properties before every start. Even when you edited the config and set it to read only, the engine itself wil enable reflections again, no matter the config is set. Ubisoft has to take a look at it.

i dont know about you but when i check the files after i close the game or restart it they still show the changes i made, so my files dont reset.

TheSaftschubse
11-18-2014, 10:24 AM
i dont know about you but when i check the files after i close the game or restart it they still show the changes i made, so my files dont reset.

Yeah, but the engine itself still changes the reflections again when no changes are made to the config files. It doesn't matter whether it's set to 0 or not.

OppaRex
11-18-2014, 01:38 PM
worked for me the first time.... gained around 10 fps
And came back to normal after I restarted the game... No matter what all I do... It just dsnt work anymore...

topeira1980
11-18-2014, 04:52 PM
Yeah, but the engine itself still changes the reflections again when no changes are made to the config files. It doesn't matter whether it's set to 0 or not.

oh.... hmmm...

i set to original values and walked around notre dame and got about 22 fps in the sides of the cathedral. switched to the TWEAKED files and got the same fps. now im wondering if the tweak just isnt working any more or if it ever did and the reason i thought the game performed better just because i was in a "light" district.

MauriceWijma
11-19-2014, 02:25 AM
Well, my experience is that the game works some of the times. Some times it gives me a reasonably smooth gameplay, mostly it stutters wildly and gives lower fps. Another sign that it is the game that is broken, and not the hardware.

small2assassins
11-19-2014, 03:02 AM
Help me please someone, I downloaded this game since my PC ran black flag great, but I can't get unity to work properly.
I have a GTX 650 OC'ed to 1.25 GHz and AMD Phenom X3 8750B.
The frame rate is terrible at around 3-10 fps at most with terrible frametimes, I've tried everything including turning the resolution down to 640x480 and all settings to low but IT DOESN'T AFFECT FPS AT ALL. I am about to give up on this game now. And the thing is I monitor all the resource usage using MSI Afterburner and my CPU stays at around 50-60% while my GPU is running at around 20-25% at best. And for the record I am not exceeding any VRAM limits at all, it stays at a reasonable 800-900 MBs.
I've also tried every possible combination in Nvidia Control panel and to no avail.
I must mention a strange thing though, if I turn all settings to ultra high, AA off, bloom off, and run at my native res of 1440x900, I get around 25 fps when I climb a tower and stare at the horizon. Now it only happens when I stare at the horizon, not the sky. If I stare at the sky it goes down to around 7-10 fps again. And while I am staring at the horizon, my GPU goes up to around 75-80% and CPU goes up to 75-80% too and frametimes are amazing at around 10-25ms which means absolutely smooth gameplay. I don't know why this is happening.
Please if someone has any solution to offer, I am willing to try. Any help will be appreciated. I really want to play this game, my pc runs all the other games that have come out this year just fine at mid to high. I am pretty sure it can handle AC unity too, I just don't know how to squeeze the performance out of this game. Help please!

A-p-o-l-l-y-o-n
11-19-2014, 05:51 AM
worked for me the first time.... gained around 10 fps
And came back to normal after I restarted the game... No matter what all I do... It just dsnt work anymore...

I experienced the same thing. It's like it only worked once for me.

topeira1980
11-19-2014, 10:09 AM
I experienced the same thing. It's like it only worked once for me.

are you sure that when it "worked" it wasnt due to the specifi location you were in the game? like a smoother district in paris?

TheSpoonelite
11-21-2014, 12:23 PM
Help me please someone, I downloaded this game since my PC ran black flag great, but I can't get unity to work properly.
I have a GTX 650 OC'ed to 1.25 GHz and AMD Phenom X3 8750B.
The frame rate is terrible at around 3-10 fps at most with terrible frametimes, I've tried everything including turning the resolution down to 640x480 and all settings to low but IT DOESN'T AFFECT FPS AT ALL. I am about to give up on this game now. And the thing is I monitor all the resource usage using MSI Afterburner and my CPU stays at around 50-60% while my GPU is running at around 20-25% at best. And for the record I am not exceeding any VRAM limits at all, it stays at a reasonable 800-900 MBs.
I've also tried every possible combination in Nvidia Control panel and to no avail.
I must mention a strange thing though, if I turn all settings to ultra high, AA off, bloom off, and run at my native res of 1440x900, I get around 25 fps when I climb a tower and stare at the horizon. Now it only happens when I stare at the horizon, not the sky. If I stare at the sky it goes down to around 7-10 fps again. And while I am staring at the horizon, my GPU goes up to around 75-80% and CPU goes up to 75-80% too and frametimes are amazing at around 10-25ms which means absolutely smooth gameplay. I don't know why this is happening.
Please if someone has any solution to offer, I am willing to try. Any help will be appreciated. I really want to play this game, my pc runs all the other games that have come out this year just fine at mid to high. I am pretty sure it can handle AC unity too, I just don't know how to squeeze the performance out of this game. Help please!

Hi Buddy,
How much RAM are you running? This game is designed to be very graphically intensive, your specs are a fair way below the minimum specs.The recommended specs are are a GTX 780 - a £300 card. If I was you I would wait, they clearly need to do a lot of fixing, which I hope they are on there way with. I just upgraded from a 660 to a 770 and can't get above 30 frames in 1080p never mind 1440!

A note to all though: This reflections thing did NOT work for me, I tested everything, read-only, reflectionsoff, reflections on, ='0' through to ='2'. However I'm seeing much better performance running the game in 1280x720. Anything above that loses me 10-20 frames. AND I have found that this is regardless of the other graphical settings. In 1080p I can have textures as high as i want, enviroment as high as i want, shadows on low, HBAO+ Ambient and AA off and i get 20-30 frames. Shadows and AA tank my frames to 7-9fps. In 1280x720 I get between 20-50fps depending on where I am in the city and with EVERYTHING maxed.

goug
11-21-2014, 06:53 PM
Help me please someone, I downloaded this game since my PC ran black flag great, but I can't get unity to work properly.
I have a GTX 650 OC'ed to 1.25 GHz and AMD Phenom X3 8750B.
The frame rate is terrible at around 3-10 fps at most with terrible frametimes, I've tried everything including turning the resolution down to 640x480 and all settings to low but IT DOESN'T AFFECT FPS AT ALL. I am about to give up on this game now. And the thing is I monitor all the resource usage using MSI Afterburner and my CPU stays at around 50-60% while my GPU is running at around 20-25% at best. And for the record I am not exceeding any VRAM limits at all, it stays at a reasonable 800-900 MBs.
I've also tried every possible combination in Nvidia Control panel and to no avail.
I must mention a strange thing though, if I turn all settings to ultra high, AA off, bloom off, and run at my native res of 1440x900, I get around 25 fps when I climb a tower and stare at the horizon. Now it only happens when I stare at the horizon, not the sky. If I stare at the sky it goes down to around 7-10 fps again. And while I am staring at the horizon, my GPU goes up to around 75-80% and CPU goes up to 75-80% too and frametimes are amazing at around 10-25ms which means absolutely smooth gameplay. I don't know why this is happening.
Please if someone has any solution to offer, I am willing to try. Any help will be appreciated. I really want to play this game, my pc runs all the other games that have come out this year just fine at mid to high. I am pretty sure it can handle AC unity too, I just don't know how to squeeze the performance out of this game. Help please!

I'm just exactly in the same case as you budy !

GTX 650 Ti OC with AMD FX 8320 and 16Go of ram for me.

All recent titles work smoothly even Watch Dog

But here, 1080p with all ultra options On : 6-8 Fps
480p all in low and without any AA, SSAO, or Bloom without the reflections tweak : 6-8 fps ! ...

Seems like a joke ! (but not funny at all ! )

So yes, even if the GTX 650 is a little bit below the minimum requirement, there is clearly a problem ! (what is the minimum to play below 720p seriously ?)

Fearless7life
08-16-2015, 02:16 PM
this workaround worked for me!
it reduced the stuttering entirelly and addded some extra fps.

rig:7870ATI
i7 870
8gb ram crucial ballistix

fps:30-50 average:41

i just want to add something:if you dont have ReflectionQuality=0 in that file,just add it yourself,at the place where it Should be(like in that picture)

thank you very much MorusLP!!!