PDA

View Full Version : Sound in FB 1.1b



XyZspineZyX
08-13-2003, 01:10 AM
Singleplayer: Perfect !

Multiplayer:

In some planes to loud, in some too quiet

In some planes you can`t hear the Flaps, in others the brakes, or wind.

You`ll never hear bullet hits in your plane.

Engine Sounds of other planes are louder than your own...

The sound has some weird echo or tunnel effect sometimes..


----------------

I don`t think it`s a Soundcard issue as (like I wrote above) in Singleplayer the Sound works perfect for me...

<Center><div style="width:150;color:red;font-size:11pt;filter:shadow Blur[color=red,strength=5)">Greets HerzAS</div><CENTER>

<Center>http://64.176.32.40/IL-2/PIGZBADGE-small.gif </center>
<center>BlitzPig_Herz</center>

XyZspineZyX
08-13-2003, 01:10 AM
Singleplayer: Perfect !

Multiplayer:

In some planes to loud, in some too quiet

In some planes you can`t hear the Flaps, in others the brakes, or wind.

You`ll never hear bullet hits in your plane.

Engine Sounds of other planes are louder than your own...

The sound has some weird echo or tunnel effect sometimes..


----------------

I don`t think it`s a Soundcard issue as (like I wrote above) in Singleplayer the Sound works perfect for me...

<Center><div style="width:150;color:red;font-size:11pt;filter:shadow Blur[color=red,strength=5)">Greets HerzAS</div><CENTER>

<Center>http://64.176.32.40/IL-2/PIGZBADGE-small.gif </center>
<center>BlitzPig_Herz</center>

XyZspineZyX
08-13-2003, 01:15 AM
Yeah, for me the sound would be perfect then suddenly it would sound muffled and stay that way through the rest of the mission...The only plane I haven't experienced this with is the P-47, so I guess the problem exists on a plane-by-plane basis....

47|FC
http://www.wpafb.af.mil/museum/research/p47-6.jpg

XyZspineZyX
08-13-2003, 01:16 AM
I'm getting my new PC next week. I will have a 6 speaker system and a 56k modem (don't intend on playing online). So, this is great news for me.

XyZspineZyX
08-13-2003, 01:20 AM
I get normal sound for about 5 secs, then all sounds except for my guns and radio voices goes to about 10% normal volume. Anyone else have this problem?

XyZspineZyX
08-13-2003, 01:22 AM
Ummm...read my earlier post.../i/smilies/16x16_smiley-wink.gif ..but in short,yes, I too have this problem....

47|FC
http://www.wpafb.af.mil/museum/research/p47-6.jpg

XyZspineZyX
08-13-2003, 01:38 AM
Same here. I heard that it's a bug whenever AAA is firing though I have yet to test it out. Oh, and it happens in a P-47 too, that was the first plane I tried out.




<center>http://members.rogers.com/4xtreme/chbanner.jpg

XyZspineZyX
08-13-2003, 01:41 AM
must depend on your sound card

XyZspineZyX
08-13-2003, 01:43 AM
Fly a quick mission where you have to attack armor. Whenever you get near the tanks/cars/AAA, your engine noise gets really quiet. It happens everytime with ground attack missions but I never get this problem when there are no ground units. Same with MP >/i/smilies/16x16_smiley-sad.gif Strange bug...


http://home.grics.net/~donovan/lzsymbls.jpg
"Though the course may change sometimes, rivers always reach the sea."

XyZspineZyX
08-13-2003, 01:43 AM
I had those problens with the leaked patches, but the 1.1b patch sound has been perfect for me so far.

Buzz_25th
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------47|FC=-
<center>
http://www.vfa25.com/images/imglib/Vfa25.jpg


Message Edited on 08/12/0305:45PM by BuzzU

XyZspineZyX
08-13-2003, 01:51 AM
My theory:

Normally when the player fires his gun, the engine volume is decreased. It appears now that when any gun is fired (AAA,etc.) the player's engine volume is decreased.

XyZspineZyX
08-13-2003, 02:08 AM
Yep that is one of the first things that I found.. and mind happend in the P47.
But the sound came back in a few min... with great sound.. But I saw that EAX was loaded and with that I had the tunnel effect in the sound. Also the bass in the sound would over push my headphones and wash them out for a little while I was on the ground and some times in the air..
And at this time I can't run with 32 voices on the sound setting , had to go back to 16 or I had glitchy sound..

ShadowHawk__
08-13-2003, 02:15 AM
Dash C seems to have gotten it right on, that's what I noticed too.

-----------------------
http://www.geocities.com/tk_shadow_hawk/shadowhawk_sig2.txt
-Death From Above

XyZspineZyX
08-13-2003, 02:16 AM
Dash_C. wrote:
- My theory:
-
- Normally when the player fires his gun, the engine
- volume is decreased. It appears now that when any
- gun is fired (AAA,etc.) the player's engine volume
- is decreased.
-
-

That's what I thought too but if you load up a QMB with you alone attacking armor and there's no AAA/no guns shooting, everything still gets quiet once you get near the convoy. Has anyone figured out a way to replace the new SFS files with old ones or something? I remember that has been done before when there was sound problems introduced in a patch.

EDIT: Actually, you may be right. I didn't notice that the armor starts shooting also.

http://home.grics.net/~donovan/lzsymbls.jpg
"Though the course may change sometimes, rivers always reach the sea."

Message Edited on 08/12/0309:20PM by EvilBen

XyZspineZyX
08-13-2003, 03:08 AM
These problems existed as late as Beta 8, and were extensively reported; and it did no good. The sound is exactly as it was in Beta 8: buggered.

And don't put too much hope in fixing it by changing your equipment or fiddling with sound settings. People tried all sorts of tricks with the beta (didn't you read that thread in SimHQ?) and nothing worked; and it's obviously the same bug.

Buzz, you haven't had any problems? Have you tried this? Take the QMB and set up a mission with a lot of planes over the Crimea map. When the ships' AA opens up, your sound will drop markedly - it won't go away completely, but it'll die way down - and then, after a couple of minutes, it may or may not come back up. Or the other sound may come back up but your engine goes totally silent.

Or whatever; what happens next seems to vary. But the sound drop when the flak bursts begin is something everybody I know has experienced, and nobody has so far found a system fix.

Now if you DON'T get that effect, then I'd really like to know the details of your setup, because somewhere in there may be the answer to a very big problem.

The main trigger seems to be any sort of sudden intense sound input, most commonly flak bursts but a bomb explosion or a plane blowing up can do it too. This suggests that the problem is in the sound compression; too much input in a hurry and the sound system overloads. This should not be all that difficult to fix, so I don't know why it hasn't been corrected.

All this is speaking of the bug that causes the sound to die away. There IS a fix, though, for the problem of the engine sound cutting out when you fire your guns. Go into your audio settings and set it for 32 channels, with sound acceleration turned off. That fixed it for me anyway.

But it won't do anything for the big bug. I don't think that one is curable at the user end; it's something in the program and the developers are going to have to fix it.

Not that I have any hope. They've been fiddling with the sound since the original Il-2 and every time they do anything to it they make it worse. It's become obvious to me that however formidable the other skills of O. Maddox and his team, they simply don't know what they're doing in this area.

Either that or the basic problems are hard-wired into the code; it's possible that there simply is no way to create a really good sound system for the Il-2 engine. That would be very easy for me to believe; it would explain much.





Blind Joe Death

aka
inada
Mulla Stondaa
Hugh G. Rexion
Heywood Jablomi
I.P. Innuendo
mogilshchik
bezumniy

(Don't tell me you didn't know.)

XyZspineZyX
08-13-2003, 05:35 AM
Nice post BJD. Makes sense.

I need more time to fool with the patch but it seems like a sound (or set of sounds) is taking a priority over the engine sound. That could be in the compression or some bad coding. Maybe it's an EAX problem. Thing is it still could be anything since it seems to affect multiple platforms like Creative and nforce.

I'll have to try out the settings some more tomorrow.



<center>http://members.rogers.com/4xtreme/chbanner.jpg

XyZspineZyX
08-13-2003, 05:39 AM
Maybe Joe. I haven't tried any busy maps yet.

Buzz_25th
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------47|FC=-
<center>
http://www.vfa25.com/images/imglib/Vfa25.jpg

XyZspineZyX
08-13-2003, 05:50 AM
Same problem here....engine volume decreases when guns are fired. I never had this problem before the patch.

I tried for about 3 hours to solve this problem but didn't have any luck...http://ubbxforums.ubi.com/infopop/emoticons/icon_frown.gif

Aviar

----------------------------------
AMD XP 2600+
EPoX EP-8K9AI Mobo
1536Mb DDR PC 2100 RAM
ATI Radeon 9700 Pro
SoundBlaster Audigy
Klipsch 5.1 THX Certified Speakers
CH FighterStick USB
CH Pro Throttle USB
CH Pro Pedals USB
Thrustmaster Tacticalboard

XyZspineZyX
08-13-2003, 06:14 AM
Aviar wrote:
- Same problem here....engine volume decreases when
- guns are fired. I never had this problem before the
- patch.
-
I think this is intentional, to give a sort of deafening effect when firing guns. But we're talking about a permanent deafening effect (although it sometimes magically disappears) even when you aren't firing guns and it usually happens after heavy fire from ground units.


http://home.grics.net/~donovan/lzsymbls.jpg
"Though the course may change sometimes, rivers always reach the sea."

XyZspineZyX
08-13-2003, 07:05 AM
Other sounds reducing as guns fire does not sound natural at all. There is a momentary fading out of the other sounds before you even hear the gunfire. How is that natural? I can understand the sound fading back in, but fading out before the sounds? It sounds especially bad in the gunner positions on the He-111.

XyZspineZyX
08-13-2003, 07:10 AM
Of course it's not natural....it's a sound bug. I just flew online and now I'm getting sound problems that others are reporting: Engine sound decreasing when AA guns are shooting at me.

Man, this is really disturbing. I hate it when a patch makes things worse.../i/smilies/16x16_smiley-sad.gif

Aviar

----------------------------------
AMD XP 2600+
EPoX EP-8K9AI Mobo
1536Mb DDR PC 2100 RAM
ATI Radeon 9700 Pro
SoundBlaster Audigy
Klipsch 5.1 THX Certified Speakers
CH FighterStick USB
CH Pro Throttle USB
CH Pro Pedals USB
Thrustmaster Tacticalboard

XyZspineZyX
08-13-2003, 08:32 AM
I was having a sound problem

The sound was fine altho Im still not using
Audio inhancments/hardware acceleration

The all of the suden the sound went DOWN by like 50% or so........

Im thinking o great here we go again (had many troubles in v1.0 & il2 I have soundblaster Live Platnum was a 200 dollar card when I bought it years ago)

So here is what I did First I Pressed Shift+F2 & cycled through all the friendly ac then I went back to My ac & now the sound was normal again.... SO....... THEN.........

I pressed ESC... went too sound options in the game & turned the master volume to maximum then adjusted the Loudness USING the Objects Volume control.....

I think this has Iliminated the Problem....

I havent had that glich again yet only more time will tell..

<center><FONT COLOR="white">ӚFJ-M œ R D ˜ ӡ[/i]</font>

<center> http://www.onpoi.net/ah/pics/users/ah_109_1059752328.jpg </center>

<center><FONT COLOR="white">The "Ace Edge"(c).
With my incremental trim
I am actually able to turn so quickly that, I never turn at all.
In Fact the Planet Earth rotates around the Axis of My PC, thus giving me the optimum turn rate and insuring that you
the bandit are promptly fraged !!!
In memory Of Ray R.I.P.[/i]</font>

XyZspineZyX
08-13-2003, 08:47 AM
AFJ_Murdoc wrote:
-
- I pressed ESC... went too sound options in the game
- & turned the master volume to maximum then adjusted
- the Loudness USING the Objects Volume control.....



Pre-patch the weird muffled EAX sound issues could be fixed for the duration of a single mission by going to the sound options then exiting again, you did not need to change any settings just go in and out again and hit apply.

<center> http://groups.msn.com/_Secure/0SQDLAtUWiWZ3BKw19!aryp7v3C1h1DuNwpHOOuqhlraGSyMAY KiPEOZAA1OBgsLu*Sa0UQ2my0PiFyvNkJ5K7Clsoy7yNtEvOXY nHDuPNiotpZACY2oJxw/aircraftround.jpg </center>

XyZspineZyX
08-13-2003, 08:47 AM
AS I am in a more constructive and less whiney mood today .. the quick way to duplicate this problem is ....
run the black death track, a little way in the IL2 fly away from camera towards ground units, the engine sounds fade as one would expect, but when the camera shifts to being directly above the IL2, the sound is still way quiet.
If anyone has found a short term fix for this, then please let us know.
Just going to try Murdoc's method now ...

XyZspineZyX
08-13-2003, 09:01 AM
Nope it didn't cure it for me, as Galway above said the pre patch method to cure was as he said, or just run the sound in no hardware acceleration, but neither of these cure it in 1.1 for me /i/smilies/16x16_smiley-sad.gif



Message Edited on 08/13/0309:02AM by bartflaster1