View Full Version : Yet another typical "post-launch" post

11-15-2014, 09:27 AM
So, I was playing the game fine for a few hours, then I had to leave and take care of some things. When I came back I started the game and I see the very first logo screen (the Ubisoft one I think) and hear the "chime" sound that goes along with it and then......nothing. I mean absolutely nothing. Stale mate, I tried letting it load, nothing. My keyboard doesn't lock up (thank god) so all that is left to do is Ctl+Alt+Del to bring up task manager and forcibly exit the process.

Not one thing has changed from the first time I played it, up until the second time I played it. I have no clue, there is nothing on the internet about this yet (as it is still too new of a release) I'm so sick of this same ol' "song and dance". Every Ubi title always has something that is a major game-breaker.

I have tried everything I can think of under the sun...

Video drivers -fully updated
Mobo, audio, blah, blah blah, all updated to the latest.
I've verified game cache numerous times.
With or without SLI, doesn't matter, no change.

I'm not even going to ask who's decision this was to put this out on the market and all the other questions that go along with it, because I know I'm either going to receive erroneous information, or just flat out evasive lies.

My specs are in my signature below, if anyone could shed some light on this problem, I would be grateful. :mad:

Extremely disappointed.

11-15-2014, 10:38 AM
From what I've read, the cause is the new patch and/or the game itself.