View Full Version : AC Initiates Not Linking Correctly & Completely Lost on the Purpose:

11-15-2014, 02:36 AM
I was looking to see how the XP worked on initiates and have no idea what I'm looking at, or doing. I came across the page where you get extra XP if you have Played and linked other AC games with a UPlay account, except for AC 1. I played and beaten every AC game except Unity (ATM) and its not showing that any of my games are linked. It shows that they are linked on UPlay, and Uplay is linked via AC Initiates. So all in all I should be seeing these games as being linked right? Does anyone else know how exactly to gain XP on Initiates and how to fix the linking issues with AC initiates through UPlay? Any help on this issues would be much appreciated. Thank you. :confused: :rolleyes:

11-15-2014, 03:29 AM
Hey riffkid23, Initiates is not working properly for anyone. We all seem to be facing the same problem as you. The devs are currently working on a solution.

Here's a list of known issues:

You can also follow the live blog here:

11-15-2014, 03:30 AM
I'm having the same problem, and am posting to get updates if anyone fixes it

My games used to be connected to initiates when ac4 launched, now it won't recognise them at all!

11-18-2014, 04:00 AM
Same issue here. Initiates is a fail, a complete and utter fail. On their blog they say:

"On first log in, it can take some time for the XP and games you have to appear."

Um, no. It's never worked properly and has nothing to do with first log in. I've checked for the last week and a half and I'm still sitting at 0 XP and none of my game history recognized. The system is broken, plain and simple. It's completely useless and locks out actual game content in Unity.

I've bought my last AC title. All of this extra nonsense is what's making me drift away from gaming. We've been companion-apped and micro-transactioned up the wall. Enough is enough.