PDA

View Full Version : I finally got rid of the stutter!



l Khasim l
11-15-2014, 01:03 AM
Pre-patch and shortly post patch, no matter what graphics options I selected, no matter what tricks in nVidia Control Panel/nVidia Inspector I used, the game ALWAYS stuttered. Even below 720p with everything on low. Now it dips below 30 fps sometimes, during heavy action, but with my rig (3570K @ 4,2 Ghz, 8GB RAM, 660 Ti 2GB) it's damn impressive considering it's below minimum.

Here's what to do:

1. Make a clean install of the latest drivers.
2. Patch Unity to 1.2.
3. Verified game files (for some reason Uplay wanted to redownload my game while patching due to some error, might be irrelevant, but posting it here anyway).
4. Go do My Documents\Assassin's Creed Unity and cut out/delete the two files that are there. I'm pretty sure this is the crucial step, because only after doing this my stuttering disappeared.
5. Launch Unity. Hopefully, enjoy the lack (or, at least near non-existence) of stuttering.
6. No idea if it's relevant, I was using it the whole time, but again, I think I should list it - I limited FPS to 30 via MSI Afterburner+RivaTuner Statistics Server, I activated adaptive vsync (half refresh rate, so 30hz in my case) in nVidia control Panel, I have the in-game V-sync set as ON, stretching ON, refresh rate on 60 and resolution on 1080p (my native).

At first I launched the game with everything set on High, and then went down from here to get somewhat smooth framerate. I ended up with using SSAO, Bloom, Textures on High and everything else on Low + no AA. Framerate isn't locked to 30, but stuttering is definitely gone. I can finally enjoy playing the damn game, and I just finished sequence 5 and lots of side and coop missions.

Now, the game still runs like crap considering, but at least I don't get all the annoying hitches and the physics based objects don't bounce like crazy during cutscenes. I can tolerate dips below 30fps, but this constant mini-freezing was driving me nuts. Now it's gone! And I tried disconnecting from the Internet, using some elaborate tricks from the Internet and some "optimal" in-game settings,nothing of it worked in the long term.
Also, one thing I noticed - after deleting the files, my VRAM usage dropped dramatically. It used to sit on 1800-1900MB, now it's about 1600.

Please let me know if it helped you.

dbgager
11-15-2014, 02:43 AM
Those are your config/settings files. SO all your doing is forcing the game to rewrite them with default settings.

Domagoj126
11-15-2014, 03:10 AM
Here are my nvidia tweaks that helped me with performance:
*also patch 1.2 improved FPS

http://i.imgur.com/q4oQ542.jpg (http://i.imgur.com/q4oQ542.jpg)

Vsync ingame off, in inspector half refresh size.

Ingame settings:
Environment Quality; Very High
Texture Quality: High
Shadow Quality: High
Ambient Occlusion: HBAO+
Bloom: ON
AA: FXAA
Resolution: 1600x900

Minimal settigns on 1080p also have bad performance and almost max setting on 900p look better than low on 1080p...

PC Specs:
GTX 750 TI 2GB OC
Phenom II x4 955 BE @3.9 GHz
8GB DDR3 (http://i.imgur.com/am2pEX4.jpg)

Screenshot gallery (https://www.flickr.com/photos/doktor1/sets/72157649270449471/)

https://farm6.staticflickr.com/5609/15604962858_2cfc4b0320_z.jpg

https://farm6.staticflickr.com/5616/15605209307_fbe1dc25bf_z.jpg

https://farm8.staticflickr.com/7514/15790366865_9626a267af_z.jpg

DjKamo
11-15-2014, 11:07 AM
I'll try your solution, since i have 660gtx and god damn stuttering KILLS ME ! Already tried downgrade of drivers but it didnt help. It might be connected with those files, iI think that game "doesnt remember" that you changed specific game settings.
my rig:
AMD FX-4100 4x 3..6Ghz
GeForce 660GTX
8Gb RAM
What NVidia drivers are you using ?

Domagoj126
11-15-2014, 11:43 AM
344.65

TheSaftschubse
11-15-2014, 12:09 PM
I'll try your solution, since i have 660gtx and god damn stuttering KILLS ME ! Already tried downgrade of drivers but it didnt help. It might be connected with those files, iI think that game "doesnt remember" that you changed specific game settings.


Same here. Using a GTX660, the framerate is actually acceptable, BUT every second there is a little freeze for a split of the second. It feels like some sort of "reload-lag". Anyone else got this issue? Playing on medium-high settings.

Domagoj126
11-15-2014, 12:30 PM
See if you have nvidia Shadowpaly turn on! Turn it off; may be reason of some sttutering...

totte115
11-15-2014, 12:43 PM
For me its somewhat smooth now, around 40 FPS

BUT the ****ing mouse is acting weird.
If I drag it in same speed to any direction it will "lag" ingame, doing different speeds ingame, which kills my ****ing sanity

Domagoj126
11-15-2014, 12:47 PM
Gamepad... :)

totte115
11-15-2014, 12:48 PM
Gamepad... :)

Im not going to ****ing use a gamepad.

Only reason why I am on PC is because I hate gamepads

lamelas86
11-15-2014, 01:28 PM
Here are my nvidia tweaks that helped me with performance:
*also patch 1.2 improved FPS

http://i.imgur.com/q4oQ542.jpg (http://i.imgur.com/q4oQ542.jpg)

Vsync ingame off, in inspector half refresh size.

Ingame settings:
Environment Quality; Very High
Texture Quality: High
Shadow Quality: High
Ambient Occlusion: HBAO+
Bloom: ON
AA: FXAA
Resolution: 1600x900

Minimal settigns on 1080p also have bad performance and almost max setting on 900p look better than low on 1080p...

PC Specs:
GTX 750 TI 2GB OC
Phenom II x4 955 BE @3.9 GHz
8GB DDR3 (http://i.imgur.com/am2pEX4.jpg)

Screenshot gallery (https://www.flickr.com/photos/doktor1/sets/72157649270449471/)

https://farm6.staticflickr.com/5609/15604962858_2cfc4b0320_z.jpg

https://farm6.staticflickr.com/5616/15605209307_fbe1dc25bf_z.jpg

https://farm8.staticflickr.com/7514/15790366865_9626a267af_z.jpg

Dude... this made wonders. My computer is pretty much the same than yours (4 cores 3,20 GHz), and its working perfectly with no slowdowns at all, even though, without having tested it much, I feel like your screenshots look much better than my game :(.

Thank you.

silverfall1986
11-15-2014, 01:33 PM
If you want to know for sure if your hardware is actually being utilized in this game then do yourself a favor by monitoring what your GPU is actually doing while playing the game. This way you can know for certain if any settings you're changing will actually make any difference or no difference at all. If the game isn't utilizing your gpu (graphics card) properly, then no setting you change is going to improve your situation, other than simply making the game run at a playable framerate even though your GPU might only be utilized by as low as 50%

How to monitor your graphics cards GPU utilization while in-game in real-time:

Choose only one.

Get MSI afterburner / nvidia or amd compatible / http://event.msi.com/vga/afterburner/download.htm/ (make sure you install rivatuner if it asks you when installing afterburner).

Optional: or if using nvidia you can try precision X: http://www.evga.com/precision/

I recommend afterburner, its less intrusive on the game itself and more stable at the moment.

You will need to run Uplay, the games executable (.exe), and ONE (choose one) of these software, all as administrator, to be 100% sure that it will work without any issues. (google it if you don't know how to run something as admin, its a little trickier on windows 8).

In the options for either software you should see something called OSD (on screen display). Turn on gpu monitoring for the OSD and make sure OSD is on (google it if you need help for whatever software you chose to use if you're having a hard time enabling it, should be easy though).

Play the game for a while, if you did it correctly you should see your gpu utilization in the corner while in-game as a % number. It should be a solid 99% or 98% if the game is using your gpu properly AT ALL TIMES. Even if the FPS drops drastically that number should be 99 or 98% (it means your gpu is actually being used).

I am curious to see if this game is plagued by the same problem watch dogs is, where gpu utilization plummets down to 50-70%. That shouldn't be happening, especially during FPS drops where you want gpu at 99% ( I.E 99% means its actually working). If its dropping down to 70% or lower, that is the cause of the performance issues. Even in absolute intense situations the gpu should be staying at 99% load. It should not be dropping, it does this in watch dogs because of their crappy engine that they cannot fix, but I'm just curious if its happening in ACU as well. So if some of you could do this for me and then report that back here with those results I'd appreciate it. Why do I want to know? Meh, I find this sort of thing fascinating, especially when they intentionally release a broken game, knowing its broken, can't fix it, and don't offer refunds. I do not own the game (dodged that burn) so I cannot check this myself.

It shouldn't matter what card you have, or if amd or nvidia. If its dropping gpu utilization hugely it shouldn't be doing that. Period. If its happening, its happening on any gpu, as is also the case with watch dogs.

Something tells me you're going to see massive gpu utilization drops but we'll see. You can post me those results either here or in this thread

http://forums.ubi.com/showthread.php/951137-Can-you-guys-tell-me-what-the-GPU-utilization-is-like

if you're curious to see what it looks like when a game engine properly uses your hardware, download and run heaven benchmark 4.0 or valley benchmark 1.0 (they are free, google it), then monitor your gpu in those benchmarks and you will see a stable 99% which is what it should be doing for any game.

Dag_B
11-15-2014, 02:04 PM
Same here. Using a GTX660, the framerate is actually acceptable, BUT every second there is a little freeze for a split of the second. It feels like some sort of "reload-lag". Anyone else got this issue? Playing on medium-high settings.
Have you checked if Vsync is to blame? They use only double Vsync which (if I remember correct) can cause such things as it will lag a little bit every time it loads from the buffer. Would have to check for exact technical explanation, but it was the reason why we all tended to use an external program for Vsync, which was able to use triple buffering which do not have this problem.

TheSaftschubse
11-15-2014, 03:03 PM
Have you checked if Vsync is to blame? They use only double Vsync which (if I remember correct) can cause such things as it will lag a little bit every time it loads from the buffer. Would have to check for exact technical explanation, but it was the reason why we all tended to use an external program for Vsync, which was able to use triple buffering which do not have this problem.

The problem also accurs when disabling Vsync completely. I'm going to upgrade to a gtx770 Phantom with 4GB, hopefully i can play at 1080p on high with FXAA then. I assume its a Vram related issue, although changing the texture resolution doesn't do the trick neither...

topeira1980
11-19-2014, 10:10 AM
man, this game drives me nuts. i have a R9 280, which is better than a 750ti, but in way to many cases i get 22fps... if you guys can run it on 750s than it's really frustrating i cant with a 280...