View Full Version : Stuck at loading screen after co-op crash and patch 2

11-14-2014, 10:20 PM
Hey guys n girls! Maybe you could help me. I was happily playing Unity on my laptop without to many problems when I tried to do my first co-op mission. The game found a partner for me en then the game crashed. "ACU.exe has stopped working" was the message. No problem, I'll start the game again. Unity notified me that the game could be updated, so I did. After the update was complete I started the game. Pressed Continue in the Main Menu. Loading before the update usually took quite a long time, but after the update it doesn't stop. I tried four times already, three times in online mode, once in offline mode (one time the intro sequence of Unity started playing, so I alt-f4'ed the game. I thought that this was very strange:confused:). Every time I've waited around 15 to 20 minutes at the loading screen. My progression is still visible next to the continue button in the main menu. Maybe my savegame has gone corrupt because I updated when the game just crashed.

If Uplay has the urge to work, I'll try verifying the game files. But if that doesn't work, I don't know what to do. So maybe you may have some things I could try:rolleyes:.
Thanks in advance!

ps. I tried to access the Ubisoft support site, but when I log in I get a 404 message. So that's not really an option...

EDIT: Well... I verified the files. A few were corrupted. Let Uplay fix them. Started the game. Unfortunately it seems my savefiles are gone. After pressing through the start screen the intro starts:(.

EDIT 2: I works in offline mode now! A bit strange though...