View Full Version : Assassin's Creed 1 doesn't seem to work on Windows 7 64 Bit

10-04-2014, 10:25 PM

I'm sure my computer meets the system requirements, as I built this computer myself a month ago and it's pretty clear to me there shouldn't be any problem there.

However, the game keeps crashing about 30 seconds in. I've got the physical copy of the game, but I read that Steam users have to disconnect their internet in order to play the first Assassin's Creed, because then it cannot try to connect to Ubisoft servers which no more exist. I'm not entirely sure if this works for me, as I was did not want to test the game for too long after trying to fix it for so long and I don't really want to have to disconnect the internet every time I want to play this game.

Wonder if there's any fixes on this yet...

10-05-2014, 12:20 AM

i recently played the AC1 with windows 8.1 but i ddint have anyproblems.. so it should work fine..
i do tho had the problem with the game just shutting down with several games excl ac series. Try downloading the latest drivers for you grafic card, if u are using beta now go to stable and if u are using stable trythe beta. i have had to do that a couple of times..


10-05-2014, 02:18 PM
I got it working. Here's what I did:

I uninstalled the game (think it was second time I did this). I installed all the unnecessary Windows 7 updates (my computer noted the updates as unnecessary). I installed Assassin's Creed 1 from the disc (starting the whole installation process from beginning) and here's what I believe is the reason it works now; after the installation is complete, the game asks do I want to register to Ubisoft now. I checked the "remind me in 7 days" and closed that window. Now that I didn't register the game, it doesn't try to access Ubisoft servers, which as I heard doesn't exist anymore, which caused the game to crash in the first place (the game trying to access those servers in the first place).

I also got my Xbox 360 wired controller for Windows working on this game as well. Here's how: I connected the controller and restarted the computer. After that I ran Assassin's Creed and there it was on the controller options "Xbox 360 controller", I chose it and it works just fine now.

Hope this helps those with similar problems.

10-05-2014, 08:07 PM
It seems most responders have had different and puzzling problems. For what it is worth, I had no problem running AC1 (or any other title of the series so far) with Win 7 64 bit pro. I also installed from disk, but I do not like and try not to use Steam for anything I can avoid.I didn't even realize that Steam is entangled with these games -- I have not seen any trace of it. However, I can attest (since I am using it every day) that the Uplay servers are very much active and work just fine. You DO have to get the game onto their server, which is not very easy in AC1 since it was written so long ago (but the process becomes automatic with subsequent titles.) You do not have to get Steam involved in any way. Once you have the game on the Uplay server, you can either play from there, or you can play from your local game files (easy to choose). Advantage of using the server is that if your local gamefiles are corrupted, you will still have a fully functional game to play, with no loss of save files, and you can play from any computer, even if it does not have a copy of the game installed.. BTW the Ubisoft tech support team is very helpful, and if you have any concerns or problems getting your game onto the Uplay server, they will do it for you. Call 1-919-460-9778 to reach them weekdays up to midnight EST. They will create a Uplay account for you and help with getting AC1 registered onto the server.
One caveat for the entire series: all of them were originally written for consoles and ported to the PC. I understand that the next and maybe last title will not be released for the PC which for me means I will skip it.The keyboard-mouse controls are a bit complex and take some experience to get comfortable with (Lefties like me should probably customize the keyboard to use the keys with the right hand and the mouse with the left -- that works for me) Still, some points in the series after AC1 (which is the simplest and easiest one, as one would expect) are sometimes frustrating because in "mini games" in the story the controls seem not to do what they generally do, The controls do not follow the usual conventions in the mini games and you have to experiment until you figure out what you have to do to get the desired effect. As Moresten pointed out above, some players have been advised to get PC-compatible console-type controllers which are supposedly easier to use. I have not done that because I have never used a console or controller for it, and kept slogging until I beat the bugs with the KB-mouse controls. If you do that, you will get a few hundred extra hours of gameplay (LOL) out of the titles because of having to replay some sequences a LOT. If you are easily frustrated, you should think hard before you go on to AC2, which is the most frustrating one in my experience.On the other hand, with a well-appointed set of hardware the graphics are hard to surpass.
Hope this helps, enjoy.

10-30-2014, 03:10 AM
The game runs fine on my system until I reach the "Memory Corridor" loading screen when entering Damascus in Memory Fragment 2. After the hint plays, the game hangs for 30 seconds and then hard crashes. Ubisoft's technical support reviewed my system information and their only solution was "My DirectX 11 is overly supported" and my "graphics card is overly supported". I bought the retail version of this game, which claims to support Windows 7, but I can't even play it! :mad:

10-30-2014, 03:16 AM
I'm sorry to say but it seems like a problem in your end, considering I already played on Windows 7 and 8, without any problems.

10-30-2014, 06:15 AM
I have Windows 7 and I've always been able to run the game fine. Just finished it again recently, in fact. So I don't think it's a Windows 7 problem. Have you tried uninstalling and reinstalling DirectX and downloading all updates for Windows? What the heck does "overly supported" mean anyway?

10-30-2014, 04:18 PM
I have to agree with the others here. It's probably your system. I have a GTX 760, and the game runs fine for me, I do however run AC1 on DX 9 because I get windowed mode with DX 10. I also have Win 7 64-bit with all the updates applied. I would guess it has something to do with your system memory, also try to install the last DirectX redist (http://www.microsoft.com/en-us/download/details.aspx?id=8109) from MS. Also if you are running any GPU optimization software (MSI Afterburner, EVGA Precisionx, etc.) then close those completely.